Create account / Log in

Setting up Java IDE for Vassal

Topics related to the main Vassal engine.

Moderators: Tim M, uckelman

Setting up Java IDE for Vassal

Postby greenknight » December 5th, 2017, 8:04 am

Hi,

I've recently been dabbling in custom classes.

It's going OK thus far. Still a lot to learn, but I'm able to build some simple classes and add them to a module.

To make life easier, I've tried to use Netbeans 8.2. Running Java 8.

That results in some warning messages, stating Vassal wants only Java 5 files.

@uckelman suggested I use -source 5 -target 5 parameters when compiling. And that works.

However, I did want to ask you how you set up your environment? Do you have any suggestions in terms of what JDk version to use, what kind of IDE software etc.

Anything that will make my life easier is very much appreciated :)
greenknight
 
Posts: 48
Joined: November 18th, 2015, 9:46 pm

Re: Setting up Java IDE for Vassal

Postby greenknight » December 9th, 2017, 1:01 pm

Disregard. Solved.
greenknight
 
Posts: 48
Joined: November 18th, 2015, 9:46 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 3 guests