Page 1 of 1

Online connectivity II

PostPosted: December 20th, 2018, 7:50 pm
by semperfi11
Some more on the problem I discussed in my first post. For the past 2 weeks anytime I connect any module to the server, I lose connection after a few minutes. If I reconnect I end up in the module twice. Has anyone else had this problem. I'm not real computer savvy and I'm not sure where to look for the answer to the problem. I would appreciated any help/advice anyone might offer.

Re: Online connectivity II

PostPosted: December 22nd, 2018, 7:51 pm
by Malnorma
This happens all the time, you just have to put up with it. The connection fails, but the server takes a while to realise it, so you get a 'ghost' user hanging around until it times out. This causes confusion, because if a ghost is the room owner, anyone joining the room does not synchronise successfully by default.

The most common cause of this in my experience is lack of activity from you. If you are using a separate program to communicate with other players (e.g. discord, skype) and not interacting with Vassal in a way that sends packets, it is more likely you will get dropped. Toggling the LFG flag every few minutes is like a poor man's keepalive that doesn't affect the game itself.

Re: Online connectivity II

PostPosted: December 27th, 2018, 6:19 pm
by semperfi11
Thanks for the advice. I'll give it a try.

Phil C

Re: Online connectivity II

PostPosted: January 10th, 2019, 12:30 am
by JohnStaal
Hi Phil,

I am still struggeling with the same issue for some years now; do you have a more robust solution than the poorman's keepalive feature?

I reported this a couple of years ago; was then regarded not a Vassal client/server issue, so must be some ISP or connection error.

But there are quite a few people out here that have same issues.

John