Create account / Log in

VASSAL 3.1.2 released

Topics related to the main Vassal engine.

Moderators: uckelman, Tim M

VASSAL 3.1.2 released

Postby uckelman » March 18th, 2009, 12:08 pm

The VASSAL Team is happy to announce the release of VASSAL 3.1.2, which
fixes a serious problem in 3.1.1.

*********************
Download
*********************

For Linux:

http://prdownloads.sourceforge.net/vass ... -linux.zip

For Mac OS X:

http://prdownloads.sourceforge.net/vass ... macosx.dmg

For Windows:

http://prdownloads.sourceforge.net/vass ... indows.exe

For other operating systems:

http://prdownloads.sourceforge.net/vass ... -other.zip

Source code:

http://prdownloads.sourceforge.net/vass ... .2-src.zip


*********************
Changes since 3.1.0:
*********************

The following bugs in 3.1.1 are fixed in 3.1.2:

* Bug 2690874: No Moved button if no text specified

The following bugs in 3.1.0 are fixed in 3.1.1:

* Bug 2689040: StringIndexOutOfBoundsException inviting peer2peer players
* Bug 2688226: NPE Adding Preference
* Bug 2687265: NPE in SendToLocation
* Bug 2687178: Mark unmoved button appears even if icon set to null
* Bug 2686890: Turn Counter does not respond to Hotkeys when undocked
* Bug 2686888: Turn Counter always increments/decrements by 1
* Bug 2685559: NPE in Embellishment.getMatchingActivationChar()
* Bug 2684931: ClassCastException when loading module
* Bug 2672959: Old Java fails to read PNGs with small palettes
* Bug 2676355: Bug Dialog sometimes hangs over other modal dialogs
* Bug 2673589: ImageIO throws IllegalArgumentException reading bad mages
* Bug 2665747: NPE in MovementReporter reporting Drag & Drop move
* Bug 2658210: OutOfMemoryError in Importer should not generate Bug Dialog
* Bug 2653477: ArrayIndexOutOfBoundsException in Embellishment.getLocalized
* Bug 2630529: NPE in ModuleManager displaying newly added module info
* Bug 2432256: ArrayIndexOutOfBoundsException in Embellishment

The recommended minimum Java version for VASSAL 3.1 has changed. A bug in
versions of Java prior to 1.5.0_08 (a.k.a. Java 5 update 8) prevents some
images from loading properly. We now recommend that anyone using a version
of Java older than 1.5.0_08 upgrade to *at least* 1.5.0_08.

For Linux and Mac users, this should require no action on your part. Windows
users installing VASSAL 3.1.2 with the Windows installer will be prompted to
update Java if what they have is older than 1.5.0_08.

For feature changes from 3.0 to 3.1, see the release notes for 3.1.0.

Please report all bugs, even if they are bugs which you've already reported
against other versions. We take your bug reports very seriously---they're
the reason we're able to find and fix bugs.


*********************
Help us test
*********************

Should you find any problems/oddities/bugs, please tell us so that we can
fix them for the next release of VASSAL.

Report bugs here in the Technical Support & Bugs category at the VASSAL
forums:

http://vassalengine.org/forums/viewforum.php?f=3

or by email to uckelman@nomic.net.


Cheers,

Joel Uckelman, for The VASSAL Team
User avatar
uckelman
Site Admin
 
Posts: 9001
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Return to General Discussion

Who is online

Users browsing this forum: marktb1961 and 2 guests