Create account / Log in

Can´t run vassal

Topics related to the main Vassal engine.

Moderators: Tim M, uckelman

Can´t run vassal

Postby uckelman » March 25th, 2009, 11:42 am

Thus spake "MadSeason":
Not that this has anything to do with what your problem is but just tonight I
had a serious problem with my Vassal and it definitely was some kind of vide
o conflict because the screen started having artifacts all over it -- even af
ter Vassal crashed and was gone. Then my computer crashed. I got my computer
started again (I had to restore!) and tried to resolve the problem by updatin
g my drivers. That seemed to solve the computer's problem but Vassal would no
t start. I uninstalled and reinstalled vassal and it still would not start. I
clicked on the icon and the clock started to spin (all this is in Vista) but
nothing ever happened. I tried this again and same result. I tried updating
Java -- it failed to update.

Do you mean that there was an update, but it failed to install, or just that
there was no update?

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8140
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Can´t run vassal

Postby uckelman » March 25th, 2009, 11:33 pm

Thus spake Joel Uckelman:
Thus spake Michael Kiefte:
Perhaps someone can suggest how to disable D3D entirely within Java?


It will be simpler for me to do a build which has D3D disabled by default,
as I think we'll want that for 3.1.3 anyway. I hope that Sun is doing
something about all of the problems with D3D support so that we subsequent
updates of Java 6 are better than 11 and 12.


First, were you able to update your video drivers? Did that help?

Second:

I've realized that making a build which disables Direct3D completely is
more complex than I first thought, because the code we have for controlling
whether Direct3D is used applies to the Player and Editor only. But it's
the Module Manager which is crashing for you.

You can turn off Direct3D for the Module Manager this way: Go to the
directory where VASSAL is installed (probaby solmething like
C:\Program Files\VASSAL). In the same directory as VASSAL.exe, create
a text file named VASSAL.l4j.ini containing the following line:

-Dsun.java2d.d3d=false

(Use a text editor to do this, e.g., notepad. Do NOT use a word processor
for this.) Once you've created this file, try running VASSAL. If you've
done this correctly and Direct3D was your problem, then the Module Manager
should start. From the Preferences in the Module Manager, you can turn off
Direct3D for the Player and Editor.

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8140
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Previous

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest