Create account / Log in

VASSAL 3.1.7 released

Topics related to the main Vassal engine.

Moderators: Tim M, uckelman

VASSAL 3.1.7 released

Postby uckelman » June 26th, 2009, 4:54 pm

The VASSAL Team is happy to announce the release of VASSAL 3.1.7, which
fixes several problems found in earlier versions.

*********************
Download
*********************

For Linux:

http://downloads.sourceforge.net/vassal ... ux.tar.bz2

For Mac OS X:

http://downloads.sourceforge.net/vassal ... macosx.dmg

For Windows:

http://downloads.sourceforge.net/vassal ... indows.exe

For other operating systems:

http://downloads.sourceforge.net/vassal ... -other.zip

Source code:

http://downloads.sourceforge.net/vassal ... .7-src.zip


*********************
Changes since 3.1.0
*********************

The following bugs are fixed in 3.1.7:

* Bug 2811307: Extraneous error messages in Embellishment following property
* Bug 2811211: Area of Effect does not display in all Zoned Grids
* Bug 2806392: Observer side linked to password
* Bug 2806183: Trigger action fails to execute another TA more than once
* Bug 2805282: SendToLocation does not undo correctly
* Bug 2804153: NPE in ModuleManager when refreshing Save Folder

The following bugs are fixed in 3.1.6:

* Bug 2798275: Layer following prop does not allow non-string custom props
* Bug 2794703: StackOverflow using Embellishment level following property
* Bug 2793103: Memory check fails on Linux due to architecture mismatch
* Bug: Transparent images used for orthogonal rotations of opaque sources
* Bug: Incorrect PropertySource used to evaluate properties
* Bug: Use bounds for primary screen on multi-monitor X11 systems.

The following bugs are fixed in 3.1.5:

* Bug 2786932: MemoryUtils.getPhysicalMemory() fails on PPC Linux
* Bug 2787242: Layer tracking Property - Report Action lags on PieceName
* Bug 2787134: NPE during map scrolling due to off-EDT Swing calls
* Bug 2785328: ImageIO fails to read size of JPEGs with bad color profiles
* Bug 2784636: NPE in MapShader.buildTexture()
* Bug 2766794: Expanded Stack of 2 pieces collapses when arrow keys used
* Bug 2659577: ImageSaver paints Boards with no background black
* Bug: Accidentally rejecting perfectly valid mask images in ADC2 symbol sets
* Bug: CounterDetailViewer calls Swing methods off EDT
* Bug: CounterDetailViewer should not appear during piece drags

* Image scaling is now 35% faster.
* Map-edge autoscrolling is now smoother and more responsive.

For changes prior to 3.1.5, see the change log.

The recommended minimum Java version for VASSAL 3.1 has changed. A bug in
versions of Java prior to 1.5.0_08 (a.k.a. Java 5 update 8) prevents some
images from loading properly. We now recommend that anyone using a version
of Java older than 1.5.0_08 upgrade to *at least* 1.5.0_08.

For Linux and Mac users, this should require no action on your part. Windows
users installing VASSAL 3.1.6 with the Windows installer will be prompted to
update Java if what they have is older than 1.5.0_08.

For feature changes from 3.0 to 3.1, see the release notes for 3.1.0.

Please report all bugs, even if they are bugs which you've already reported
against other versions. We take your bug reports very seriously---they're
the reason we're able to find and fix bugs.


*********************
Help us test
*********************

Should you find any problems/oddities/bugs, please tell us so that we can
fix them for the next release of VASSAL.

Report bugs here in the Technical Support & Bugs category at the VASSAL
forums:

http://vassalengine.org/forums/viewforum.php?f=3

or by email to uckelman@nomic.net.


Cheers,

Joel Uckelman, for The VASSAL Team
Last edited by uckelman on July 9th, 2009, 9:10 am, edited 1 time in total.
User avatar
uckelman
Site Admin
 
Posts: 8380
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Postby Doug DeMoss » June 26th, 2009, 10:32 pm

The Mac OS X app doesn't appear to work on my Intel iMac for some reason - I get the following message:

You can't open the application "VASSAL-3.1.7" because it is not supported on this architecture.


Ah, figured it out - the package structure is not right. There's an extra folder layer ("kisofsrc") that shouldn't be there inside the package - moving the Contents folder up a level in the folder hierarchy and deleting "kisofsrc" appears to work.

Doug
Doug DeMoss
 
Posts: 3
Joined: June 25th, 2009, 4:54 pm
Location: Tustin, CA

VASSAL 3.1.7 released

Postby uckelman » June 26th, 2009, 10:47 pm

Thus spake "Doug DeMoss":
Ah, figured it out - the package structure is not right. There's an extra fo
lder layer ("kisofsrc") that shouldn't be there inside the package - moving t
he Contents folder up a level in the folder hierarchy and deleting "kisofsrc"
appears to work.

Doug


Thanks for the thorough bug report.

This is the first time I've built a release on Fedora 11. Something must
have changed with the way that geniosimage builds ISOs, as I haven't
touched the Mac OS X bundle target in the Makefile in ages.

I'm about to turn in for the night, so I won't be able to fix this until
tomorrow. In the mean time, I've taken down the Mac bundle for 3.1.7 so
that no one else downloads the broken one before I get a chance to fix it.

(NB: This either means that no one tried the 3.1.7-svn Mac builds I made,
or they did but didn't tell me about the probelm. That's frustrating, as
Mac OS X is a platform which I can't test myself.)

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8380
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

VASSAL 3.1.7 released

Postby Tim M » June 26th, 2009, 11:57 pm

I have a mac now as well, so will be able to test those builds from now on

Post generated using Mail2Forum (http://www.mail2forum.com)
Tim,
Vassal Uber Geek/Guru

Problems? post your OS, Physical Mem, version of Vassal and Java plus the Module in question.
No developer can help with out that info, thx!
User avatar
Tim M
 
Posts: 1799
Joined: December 8th, 2007, 12:22 pm
Location: Earth

Postby uckelman » June 27th, 2009, 11:30 am

The Mac OS X bundle I originally uploaded for VASSAL 3.1.7 was faulty, and has been replaced. If you downloaded the original Mac OS X bundle, please download it again in order to get the repaired one. We apologize for the inconvenience.

(Long explanation: There is a bug in the version of genisoimage shipped with Fedora 11, my Linux distribution, and 3.1.7 is the first release I've built since moving from Fedora 10 to Fedora 11. In case you care, you can see the bug here.)
User avatar
uckelman
Site Admin
 
Posts: 8380
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

updating

Postby JUNO44 » July 7th, 2009, 7:41 pm

Speaking as a mediocre computer person, is there a way to upgrade the Vassal version directly or do you have to download, install,delete old add mods again?
JUNO44
 
Posts: 287
Joined: February 23rd, 2009, 11:15 pm
Location: Allanburg, Ontario, Canada

VASSAL 3.1.7 released

Postby uckelman » July 7th, 2009, 7:44 pm

Thus spake "JUNO44":
Speaking as a mediocre computer person, is there a way to upgrade the Vassal
version directly or do you have to download, install,delete old add mods agai
n?


I can't think of any reason why you'd have to delete and download your
modules again as a result of upgrading VASSAL. Can you explain why you
think you would?

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8380
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

new vassal

Postby JUNO44 » July 7th, 2009, 8:01 pm

was refering to the vassal program itself. then when starting up new version you must 're-load ' mods from your files to have them show up in selection screen. Wondered if an upgrade could just be written over old file. 3.7 over 3.14 for example.
JUNO44
 
Posts: 287
Joined: February 23rd, 2009, 11:15 pm
Location: Allanburg, Ontario, Canada

VASSAL 3.1.7 released

Postby uckelman » July 7th, 2009, 9:11 pm

Thus spake "JUNO44":
was refering to the vassal program itself. then when starting up new version
you must 're-load ' mods from your files to have them show up in selection sc
reen.

Do you mean that after upgrading you see no modules in the Module Manager?

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8380
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Duh

Postby JUNO44 » July 7th, 2009, 9:19 pm

Well while waiting I had been downloading 3.1.7. Just ran program and none of what I was asking about happened. In otherwords my program is up-dated and mods are still in library. goes to show that I was right about my computer expertise.
thanks for quick response.
Greig
JUNO44
 
Posts: 287
Joined: February 23rd, 2009, 11:15 pm
Location: Allanburg, Ontario, Canada


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 4 guests