Create account / Log in

lost module file

Topics related to the main Vassal engine.

Moderators: Tim M, uckelman

lost module file

Postby Kevan » February 6th, 2008, 2:00 am

Can anyone tell me what happens to a module file that accidentally gets dragged onto a desktop shortcut to the Vassal program? I had about 12 hours of work on updating a module, when I accidentally did this, now I can't find the module file anywhere on a computer.

Yeah, I know, this is more of a general computer question than a Vassal question, but I can't seem to google an answer.
Kevan
 
Posts: 12
Joined: January 13th, 2008, 9:55 pm
Location: Canada

Postby bsmith » February 6th, 2008, 2:23 am

I think it is just passes it as an argument to Vassal. I doubt it would have deleted your file.
User avatar
bsmith
Site Admin
 
Posts: 657
Joined: October 2nd, 2007, 4:47 pm

Postby Kevan » February 6th, 2008, 2:25 am

As an experiment, I created a new mod file and repeated the action - the new one disappeared also.
Kevan
 
Posts: 12
Joined: January 13th, 2008, 9:55 pm
Location: Canada

Postby meng » February 6th, 2008, 3:50 am

Doesn't this depend on what operating system you're using?
meng
 
Posts: 124
Joined: January 14th, 2008, 6:35 pm
Location: Melbourne, Australia

Postby Kevan » February 6th, 2008, 3:57 am

Sorry, should have thought to mention. I'm using Windows XP.
Kevan
 
Posts: 12
Joined: January 13th, 2008, 9:55 pm
Location: Canada

Postby bsmith » February 6th, 2008, 5:02 am

That's weird, it behaves differently for me with Vista. Have you tried doing a search for the file name?
User avatar
bsmith
Site Admin
 
Posts: 657
Joined: October 2nd, 2007, 4:47 pm

Postby meng » February 6th, 2008, 6:36 am

XP huh? Well, I try not to use MS-anything if I can avoid it, but did you try dragging the VASSAL shortcut onto somewhere else on the desktop, just in case your module file is "underneath" it? (That probably makes no sense, but that's what I would try if an icon just up and disappeared on me. That, and looking in the actual Desktop folder, assuming there is one.)
meng
 
Posts: 124
Joined: January 14th, 2008, 6:35 pm
Location: Melbourne, Australia

Postby bsmith » February 6th, 2008, 6:49 am

meng wrote:XP huh? Well, I try not to use MS-anything if I can avoid it, but did you try dragging the VASSAL shortcut onto somewhere else on the desktop, just in case your module file is "underneath" it? (That probably makes no sense, but that's what I would try if an icon just up and disappeared on me. That, and looking in the actual Desktop folder, assuming there is one.)


Yeah that's a good point, maybe try the "Auto Arrange" option.
User avatar
bsmith
Site Admin
 
Posts: 657
Joined: October 2nd, 2007, 4:47 pm

Postby Kevan » February 6th, 2008, 8:13 pm

Yep, tried auto-arrange, and a search with no luck. With no luck on a simple search, I tried searching for every file created in the last week, and even searching for hidden files. And it's not in my "recycle bin" either.
Kevan
 
Posts: 12
Joined: January 13th, 2008, 9:55 pm
Location: Canada

lost module file

Postby Tim M » February 6th, 2008, 8:21 pm

what about temp.zip / temp.mod files in your vassal directory? The last one will probably be close to your last working copy at least so you dont lose everything or too much

Kevan <messages@forums.vassalengine.org> wrote:
Yep, tried a search with no luck. With no luck on a simple search, I tried searching for every file created in the last week, and even searching for hidden files. And it's not in my "recycle bin" either.







_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org


Post generated using Mail2Forum (http://www.mail2forum.com)
Tim,
Vassal Uber Geek/Guru

Problems? post your OS, Physical Mem, version of Vassal and Java plus the Module in question.
No developer can help with out that info, thx!
User avatar
Tim M
 
Posts: 1799
Joined: December 8th, 2007, 12:22 pm
Location: Earth

Postby Kevan » February 7th, 2008, 2:38 am

Unfortunately, no temp file. I was doing some experiments with another module at the same time, and it was the one that got backed up into the temp file.

Just bad luck all around, it seems.
Kevan
 
Posts: 12
Joined: January 13th, 2008, 9:55 pm
Location: Canada

lost module file

Postby uckelman » February 7th, 2008, 8:42 am

Thus spake "Kevan":
Unfortunately, no temp file. I was doing some experiments with another module
at the same time, and it was the one that got backed up into the temp file.

Just bad luck all around, it seems.


I'm scratching my head over how this could happen. Is it a VASSAL bug?
A Windows bug? Does the same thing happen if you drag a random file onto
any desktop shortcut?

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8373
Joined: December 10th, 2007, 9:48 am
Location: Durham, England


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest