Create account / Log in

The Forum

Topics related to the main Vassal engine.

Moderators: Tim M, uckelman

The Forum

Postby bsmith » December 10th, 2007, 12:08 pm

Could we call the mailing list 'forum'? Or would that be too confusing?


Just moved the discussion here Joel...

That's up to Rodney, he's the boss as far as naming the list goes.

Ben
User avatar
bsmith
Site Admin
 
Posts: 657
Joined: October 2nd, 2007, 4:47 pm

Postby bsmith » December 10th, 2007, 12:20 pm

Hmmm, I still think it may require more areas though.
Just a minute ago I thought I would start a new thread announcing a module I created... but where would I do this?
If I was a new visitor I would be confused as to whether I should post under Module Design, Module Support or General Discussion; This could lead to people posting under the wrong areas and causing a mess.

thoughts?
User avatar
bsmith
Site Admin
 
Posts: 657
Joined: October 2nd, 2007, 4:47 pm

The Forum

Postby uckelman » December 10th, 2007, 12:24 pm

Thus spake "bsmith":
Hmmm, I still think it may require more areas though.
Just a minute ago I thought I would start a new thread announcing a module I
created... but where would I do this?
If I was a new visitor I would be confused as to whether I should post under
Module Design, Module Support or General Discussion; This could lead to peopl
e posting under the wrong areas and causing a mess.

thoughts?


Maybe we need an Game Modules:Announcements forum? (Maybe also a
Vassal Engine:Announcements forum, for things like release announcements?)

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8130
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Postby bsmith » December 10th, 2007, 12:35 pm

For release announcements we could probably just use a sticky thread in General Discussion, like the one in there right now; This would ensure the post always stays at the top of the thread.
We just put a Sticky up there called "Latest Stable Release" or something like that, then just update the first post as we release new versions.

But I do think we need a dedicated area for Module announcements, maybe even just Modules:General Discussion would suffice.
User avatar
bsmith
Site Admin
 
Posts: 657
Joined: October 2nd, 2007, 4:47 pm

The Forum

Postby uckelman » December 10th, 2007, 12:36 pm

Ben, three more things about forum setup:

1. Have you tested what happens when a forum user not subscribed to the
mailing list posts to the forum? I.e., does their post show up on the
mailing list?

2. It would be good to set Mailman to deHTML messages, otherwise we're
going to end up with a lot of quoted garbage on the forum.

3. About the subdomain: The first two things I'd try if I couldn't
remember the subdomain are "forum" and "fora", not "forums". Once
we've gone public, were stuck with it, so we should think about whether
this is the subdomain we want. (I don't think of what we have in the
plural, hence my preference for "forum".)

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8130
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: The Forum

Postby bsmith » December 10th, 2007, 12:43 pm

uckelman wrote:Ben, three more things about forum setup:

1. Have you tested what happens when a forum user not subscribed to the
mailing list posts to the forum? I.e., does their post show up on the
mailing list?


There should be no effect in this case, the message should still be forwarded normally. I have not tested it yet though.

uckelman wrote:2. It would be good to set Mailman to deHTML messages, otherwise we're
going to end up with a lot of quoted garbage on the forum.


It does get rid of quoted garbage at the end of messages, I added a bunch of regular expressions to chop it all out. I'll just see how this goes. at this stage it looks clean but I'm aware that I'll need to adjust things as we go ahead.

uckelman wrote:3. About the subdomain: The first two things I'd try if I couldn't
remember the subdomain are "forum" and "fora", not "forums". Once
we've gone public, were stuck with it, so we should think about whether
this is the subdomain we want. (I don't think of what we have in the
plural, hence my preference for "forum".)


This was discussed some time ago, I did mention this exact concern but I believe Rodney wanted to stick to the plural "forums"; I do agree with you here.

Ben

P.S. Where the heck does "fora" come from? Jurassic Park? :D
User avatar
bsmith
Site Admin
 
Posts: 657
Joined: October 2nd, 2007, 4:47 pm

The Forum

Postby uckelman » December 10th, 2007, 12:50 pm

Thus spake "bsmith":
uckelman wrote:
Ben, three more things about forum setup:

1. Have you tested what happens when a forum user not subscribed to the
mailing list posts to the forum? I.e., does their post show up on the
mailing list?


There should be no effect in this case, the message should still be forwarded
normally. I have not tested it yet though.


I made a test account so I could test this. As soon as I receive the
confirmation email for it, I'll try it and let you know what happens.

uckelman wrote:
2. It would be good to set Mailman to deHTML messages, otherwise we're
going to end up with a lot of quoted garbage on the forum.


It does get rid of quoted garbage at the end of messages, I added a bunch of
regular expressions to chop it all out. I'll just see how this goes. at thi
s stage it looks clean but I'm aware that I'll need to adjust things as we go
ahead.

The setting I'm referring to is under "Content Filtering". It's called
convert_html_to_plaintext. This is something that I'd exepect most list
readers would want anyway.

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8130
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Postby bsmith » December 10th, 2007, 12:54 pm

OK, I've set that to Plain Text so see how it goes.
User avatar
bsmith
Site Admin
 
Posts: 657
Joined: October 2nd, 2007, 4:47 pm

The Forum

Postby uckelman » December 10th, 2007, 1:00 pm

Thus spake "bsmith":

This was discussed some time ago, I did mention this exact concern but I beli
eve Rodney wanted to stick to the plural "forums"; I do agree with you here.

Ben


Fascinating. I didn't see your PS until I looked at the message in
the forum. Something chopped it off when it went out to the list.

"fora" is the plural form of "forum" in the nominative, accusative,
and vocative cases in Latin, so says my resident Latin expert (my wife).

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8130
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

The Forum

Postby uckelman » December 10th, 2007, 1:01 pm

Thus spake "bsmith":
OK, I've set that to Plain Text so see how it goes.


Thanks. It should go fine. All of the Mailman lists I admin
are that way, and it works quite nicely.

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8130
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

The Forum

Postby uckelman » December 10th, 2007, 1:08 pm

Thus spake Joel Uckelman:
Thus spake "bsmith":
OK, I've set that to Plain Text so see how it goes.


Thanks. It should go fine. All of the Mailman lists I admin
are that way, and it works quite nicely.

Also, the Reply-to: Couly you set the reply_goes_to_list to "This list"?
Otherwise we're going to end up with a lot of unintentional off-list
posting.

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8130
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Forum confirmation email has no From or Sender headers

Postby uckelman » December 10th, 2007, 1:33 pm

I spotted another potential problem just now: The confirmation email sent by phpbb has neither a From nor a Sender header, which makes it pretty likely to be flagged as spam. If there's an admin address associated with the forum, the From should be set to that. If not, I'd suggest setting the From to messages-owner@forums.vassalengine.org, the admin address for the mailing list.
User avatar
uckelman
Site Admin
 
Posts: 8130
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Postby bsmith » December 10th, 2007, 1:41 pm

OK, I've made those two previous requested changes. Also set the Admin e-mail to messages-owner@forums.vassalengine.org.
User avatar
bsmith
Site Admin
 
Posts: 657
Joined: October 2nd, 2007, 4:47 pm

The Forum

Postby uckelman » December 10th, 2007, 1:43 pm

Thus spake "bsmith":
OK, I've made those two previous requested changes. Also set the Admin e-mai
l to messages-owner@forums.vassalengine.org.


Thanks.

Posts to the forum by non-list subscribers do make it to the list,
so that works.

You can delete the two test accounts I created---uckelmantest and
uckelmantest2---since I've now tested what I set them up to test.

--
J.

_______________________________________________
Messages mailing list
Messages@forums.vassalengine.org
http://forums.vassalengine.org/mailman/ ... engine.org

Post generated using Mail2Forum (http://www.mail2forum.com)
User avatar
uckelman
Site Admin
 
Posts: 8130
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

registration email now has correct From

Postby uckelman » December 10th, 2007, 1:48 pm

I tried to register another account, uckelmantest3, to check that the registration email From is correct. It is, so you can delete that test account as well.

I'm satisfied that things work now, with the exception of the PS from one of the messages up this thread being cut off when it went out to the mailing list.
User avatar
uckelman
Site Admin
 
Posts: 8130
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Next

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest