Create account / Log in

Vassal will not open modules

Issues with the Vassal engine.

Moderators: Tim M, uckelman

Vassal will not open modules

Postby Flamebeast » September 24th, 2017, 6:52 pm

Hi All,

Running Vassal 3.2.17 on 64 bit windows 10, with 64 bit Java installed, to run the 7.4.1 version of the X-wing module. Worked fine last week, today it doesn't. So far I have:

- removed and reinstalled Vassal and Java
- re-downloaded X-wing 7.4.1 and Vassal 3.2.17 for fresh installs
- manually downloaded 64-bit Java to make absolutely sure I'm using the right version
- disabled my firewall

None of these has had any effect on the problem - when I try to open a module, the windows loading icon appears whenever i mouse over vassal, and i can still click on the menus and make changes. The startup window for the module *sometimes* flashes up and disappears instantly, but I don't think I have any control over what's making this happen.
Flamebeast
 
Posts: 3
Joined: September 24th, 2017, 6:36 pm

Re: Vassal will not open modules

Postby Flamebeast » September 26th, 2017, 7:00 am

Update - I have managed to get it to work. No idea how, but not clicking away to other windows and waiting 5 minutes (literally) seems to allow it to open modules. No idea why it's taking so long all of a sudden, used to be a matter of a few seconds before.
Flamebeast
 
Posts: 3
Joined: September 24th, 2017, 6:36 pm

Re: Vassal will not open modules

Postby uckelman » September 26th, 2017, 4:27 pm

Thus spake Flamebeast:
> Hi All,
>
> Running Vassal 3.2.17 on 64 bit windows 10, with 64 bit Java installed,
> to run the 7.4.1 version of the X-wing module. Worked fine last week,
> today it doesn't. So far I have:
>
> - removed and reinstalled Vassal and Java
> - re-downloaded X-wing 7.4.1 and Vassal 3.2.17 for fresh installs
> - manually downloaded 64-bit Java to make absolutely sure I'm using the
> right version
> - disabled my firewall
>
> None of these has had any effect on the problem - when I try to open a
> module, the windows loading icon appears whenever i mouse over vassal,
> and i can still click on the menus and make changes. The startup window
> for the module *sometimes* flashes up and disappears instantly, but I
> don't think I have any control over what's making this happen.

Post your errorLog.

http://www.vassalengine.org/wiki/Error_Logs

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8382
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Vassal will not open modules

Postby Flamebeast » September 26th, 2017, 7:31 pm

2017-09-26 18:32:09,207 [0-main] INFO VASSAL.launch.StartUp - Starting
2017-09-26 18:32:09,209 [0-main] INFO VASSAL.launch.StartUp - OS Windows 10 10.0
2017-09-26 18:32:09,209 [0-main] INFO VASSAL.launch.StartUp - Java version 1.8.0_144
2017-09-26 18:32:09,209 [0-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.17
2017-09-26 18:32:09,276 [0-AWT-EventQueue-0] INFO VASSAL.launch.ModuleManager - Manager
2017-09-26 18:32:12,718 [0-SwingWorker-pool-1371477515-thread-1] INFO VASSAL.launch.AbstractLaunchAction - Loading module file C:\Program Files\VASSAL-3.2.17\Star_Wars_X-Wing_Miniatures_Game-7.4.1 (1).vmod
2017-09-26 18:32:13,960 [0-SwingWorker-pool-1371477515-thread-1] INFO VASSAL.launch.TilingHandler - No images to tile.
2017-09-26 18:32:13,962 [0-SwingWorker-pool-1371477515-thread-1] INFO VASSAL.launch.AbstractLaunchAction - Loading module Star Wars X-Wing Miniatures Game
2017-09-26 18:32:13,967 [0-SwingWorker-pool-1371477515-thread-1] INFO VASSAL.tools.io.ProcessLauncher - launching C:\Program Files\Java\jre1.8.0_144\bin\java -Xms256M -Xmx512M -DVASSAL.id=1 -DVASSAL.port=63407 -Duser.home=C:\Users\craig -Duser.dir=C:\Program Files\VASSAL-3.2.17 -cp lib\Vengine.jar VASSAL.launch.Player --load -- C:\Program Files\VASSAL-3.2.17\Star_Wars_X-Wing_Miniatures_Game-7.4.1 (1).vmod
2017-09-26 18:32:14,565 [1-main] INFO VASSAL.launch.StartUp - Starting
2017-09-26 18:32:14,569 [1-main] INFO VASSAL.launch.StartUp - OS Windows 10 10.0
2017-09-26 18:32:14,569 [1-main] INFO VASSAL.launch.StartUp - Java version 1.8.0_144
2017-09-26 18:32:14,569 [1-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.17
2017-09-26 18:32:14,569 [1-main] INFO VASSAL.launch.Launcher - Player
2017-09-26 18:32:16,116 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - VASSAL images folder found at jar:file:/C:/Program%20Files/VASSAL-3.2.17/lib/Vengine.jar!/images/
2017-09-26 18:32:16,118 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family network-server created for network-server.png
2017-09-26 18:32:16,118 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family go-down created for go-down.png
2017-09-26 18:32:16,118 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family network-idle created for network-idle.png
2017-09-26 18:32:16,118 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family VASSAL created for VASSAL.png
2017-09-26 18:32:16,119 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family calculator created for calculator.png
2017-09-26 18:32:16,119 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family go-up created for go-up.png
2017-09-26 18:32:16,119 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family VASSAL-jabber created for VASSAL-jabber.png
2017-09-26 18:32:16,119 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family jabber created for jabber.png
2017-09-26 18:32:16,119 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family bug created for bug.png
2017-09-26 18:32:16,119 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family yes created for yes.svg
2017-09-26 18:32:16,119 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family no created for no.svg
2017-09-26 18:35:05,737 [1-AWT-EventQueue-0] WARN VASSAL.launch.BasicModule - Star Wars X-Wing Miniatures Game version 7.4.1
2017-09-26 18:57:03,388 [1-AWT-EventQueue-0] INFO VASSAL.script.ExpressionInterpreter - Attempting to load /VASSAL/script/init_expression.bsh URI generated=jar:file:/C:/Program%20Files/VASSAL-3.2.17/lib/Vengine.jar!/VASSAL/script/init_expression.bsh
2017-09-26 20:18:50,323 [1-AWT-EventQueue-0] WARN VASSAL.tools.logging.LoggedOutputStream - Warning: Could not get charToByteConverterClass!
2017-09-26 20:18:50,323 [1-AWT-EventQueue-0] WARN VASSAL.tools.logging.LoggedOutputStream -
Flamebeast
 
Posts: 3
Joined: September 24th, 2017, 6:36 pm

Re: Vassal will not open modules

Postby uckelman » January 4th, 2018, 3:31 am

Does this problem still happen for you? If so, have you tried updating Java?
User avatar
uckelman
Site Admin
 
Posts: 8382
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Vassal will not open modules

Postby williamsgopal » September 2nd, 2018, 12:20 am

Flamebeast wrote:Hi All,

Running Vassal 3.2.17 on 64 bit windows 10, with 64 bit Java installed, to run the 7.4.1 version of the X-wing module. Worked fine last week, today it doesn't. So far I have:

- removed and reinstalled Vassal and Java
- re-downloaded X-wing 7.4.1 and Vassal 3.2.17 for fresh installs
- manually downloaded 64-bit Java to make absolutely sure I'm using the right version
- disabled my firewall

None of these has had any effect on the problem - when I try to open a module, the windows loading icon appears whenever i mouse over vassal, and i can still click on the menus and make changes. The startup window for the module *sometimes* flashes up and disappears instantly, but I don't think I have any control over what's making this happen.

he creators get explicit consent from the designers/publishers to make the module. Most don't care if there's an online implementation unless they themselves are working on one or are licensing it out to another company to make an online implementation. There are even some that do not give permission like Steve Jackson.

And the first request would be a take down request and a C&D, you wouldn't (generally) get sued unless you failed to comply.
williamsgopal
 
Posts: 2
Joined: August 10th, 2018, 12:14 am


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 6 guests