Create account / Log in

Pieces invisible after placing on board

Issues with the Vassal engine.

Moderators: Tim M, uckelman

Pieces invisible after placing on board

Postby k » January 11th, 2018, 6:55 pm

I have noticed a bug where pieces become invisible when they are dragged onto the playing board. I am not sure if this is a bug with the modules themselves or with the Vassal engine.

Here is an example of the symptoms:
1 - I have played both Star Trek Catan and Carcassone. In Catan, dragging a red settlement / starbase onto the board is visible to the blue player, but invisible to the red player. The reverse is also true, blue starbases are visible only to the red player.
1.1 - There seemed to be a "sub-bug" where, in Catan, if you placed a starbase right on a tile (instead of at its intersection, like you're supposed to), the piece was temporarily visible. But, once you moved it to the intersection like you're supposed to, it becomes invisible again.

2. In Carcassone, the problem was "reversed". Red could see the tiles he placed onto the board, blue could see his own, but neither could see the other's.

One of the players was using Vassal on MacOS 10.13 and the other was on Windows, not sure which.

Is there anything we can do to resolve these issues?
k
 
Posts: 1
Joined: January 11th, 2018, 6:44 pm

Re: Pieces invisible after placing on board

Postby DrNostromo » January 13th, 2018, 5:10 pm

I"m not familiar with those games so I don't know if this would apply but module designers can apply a trait to pieces in a game called "Invisible to Others" and define who can and cannot see them. Are you sure this is in not intentional on the designer's part?
User avatar
DrNostromo
 
Posts: 1053
Joined: December 21st, 2007, 3:54 am
Location: Wine Country, Cal. USA


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 3 guests