Create account / Log in

Send to Location Hexgrid broken

Issues with the Vassal engine.

Moderators: Tim M, uckelman

Send to Location Hexgrid broken

Postby chrono280 » January 28th, 2018, 6:27 pm

Unfortunately, I think I have discovered a bug in the way Send To Location handles hex grid coordinates.

I'm re-making the module for Space Empires 4x and in it, I am building a function that sends a counter from a given deck to a given hex coordinate on the main map. The coordinate is stored in a GP.

The counter receives the correct destination coordinate but always lands in the wrong hex. When moving the counter in that hex you can see Vassal does correctly recognize the hex coordinates, it is the Sent to Location property that is off. I believe this may be an error with the "Odd numbered rows numbered higher" option on the hex grid numbering dialog. It is as if the Send to Location function is reading the hex grid coordinates BEFORE this modification takes place.

I set the destination GP to hex L2

Image

The counter lands in L3 instead.

Image

Moving the counter a little bit shows the $Location$ is being read correctly in this moment as L3.

Image

Now trying in a different row.

Image

Counter lands in K1 instead of K2. So Even "numbered" Row L got the coordinate pushed up 1 column while odd numbered K was 1 lower than expected. Again Vassal, at least in the map and chat box are reading the coordinates correctly from $Location$.

Image
Image

The current grid hex numbering scheme which is used to match the board art.

Image

If I uncheck the "Odd numbered rows numbered higher" option. Send to Location sends the counters to the appropriate hex grid coordinate, regardless of row letter. Obviously, the grid numbering does not match the map art here but the grid coordinates show it landed in the right spot. Both went to K2 and L2 appropriately.

Image



So to me this means Sent to Location might not be picking up on the Odd numbered adjustment from the hex grid numbering dialog. Working around this could be a pain. Might just make new artwork. I don't want to build a work around for a bug that could get fixed (and then the workaround broken) in a latter release.

Any ideas?

Thanks in advance!

BTW I am running Vassal 3.2.17 on a MacBook Air 1.4ghz core i5, 4gb ram. MacOS High sierra 10.13.3
chrono280
 
Posts: 62
Joined: September 9th, 2011, 12:45 am

Re: Send to Location Hexgrid broken

Postby jphbiron » January 7th, 2019, 3:20 pm

I have the same problem too and I do not know how to solve it. Indeed it seems that this is a bug when the option "odd numbered rows numbered higher" is checked when creating the hexgrid. If not checked, "Send to location" is working normally. If checked, "Send to location" send pieces one hex right or one hex left of the target (depending on whether the hexrow is odd or not)...
jphbiron
 
Posts: 2
Joined: January 4th, 2018, 3:30 pm

Re: Send to Location Hexgrid broken

Postby chrono280 » January 8th, 2019, 3:52 pm

Yah I'm still working on the module here. I wound up just flipping the map around so that I don't use the odd rows in the same way. Completely changes the map but for this game you can get away with it. I only hope that if this is patched it doesn't break my current method.
chrono280
 
Posts: 62
Joined: September 9th, 2011, 12:45 am


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 2 guests