Create account / Log in

Bug report?

Issues with the Vassal engine.

Moderators: Tim M, uckelman

Bug report?

Postby hutonahill » December 7th, 2018, 7:21 pm

ok here is the story. I am running MacOS High Sierra version 10.13.6. I downloaded and ran the attached .dmg. I did everything it asked me to do(moved the vassal logo into the applications folder). I then ran vassal and got the following bug report:
2018-12-07 11:04:15,480 [0-main] INFO VASSAL.launch.StartUp - Starting
2018-12-07 11:04:15,483 [0-main] INFO VASSAL.launch.StartUp - OS Mac OS X 10.13.6
2018-12-07 11:04:15,483 [0-main] INFO VASSAL.launch.StartUp - Java version 9.0.1
2018-12-07 11:04:15,483 [0-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.17
2018-12-07 11:04:17,400 [0-main] ERROR VASSAL.tools.ErrorDialog -
java.lang.NoSuchMethodError: com.apple.eawt.Application.addApplicationListener(Lcom/apple/eawt/ApplicationListener;)V
at VASSAL.launch.ModuleManagerMacOSXStartUp.setupApplicationListeners(ModuleManagerMacOSXStartUp.java:36) ~[Vengine.jar:na]
at VASSAL.launch.ModuleManagerMacOSXStartUp.initSystemProperties(ModuleManagerMacOSXStartUp.java:31) ~[Vengine.jar:na]
at VASSAL.launch.ModuleManager.<init>(ModuleManager.java:280) ~[Vengine.jar:na]
at VASSAL.launch.ModuleManager.main(ModuleManager.java:183) ~[Vengine.jar:na]

Please Help me! if you need any other information or files, please let me know.

PS: I have also attached the Folder VASSAL from my ~/library/application support

FIle atachment: https://www.mediafire.com/file/d28m6rlq ... s.zip/file
hutonahill
 
Posts: 3
Joined: December 7th, 2018, 7:07 pm

Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 3 guests