Create account / Log in

What causes group select when dragging single piece?

Issues with the Vassal engine.

Moderators: uckelman, Tim M

Re: What causes group select when dragging single piece?

Postby bdgza » October 11th, 2020, 12:48 pm

Yes indeed. That fix would have a big impact.
bdgza
 
Posts: 329
Joined: February 26th, 2010, 10:51 am

Re: What causes group select when dragging single piece?

Postby uckelman » October 11th, 2020, 4:22 pm

Try please try the VASSAL-3.4.6-SNAPSHOT-0d999f4bc test build, available here:

http://www.vassalengine.org/~uckelman/tmp/
User avatar
uckelman
Site Admin
 
Posts: 8989
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: What causes group select when dragging single piece?

Postby bdgza » October 12th, 2020, 8:35 am

I tried dragging cards from a deck in a few different modules: no more band-select!

Excellent!
bdgza
 
Posts: 329
Joined: February 26th, 2010, 10:51 am

Re: What causes group select when dragging single piece?

Postby marktb1961 » October 12th, 2020, 1:01 pm

Great news that this has been fixed. Will help a lot of users (though I hadn't realised it only affected Mac).

I have been using the test build in testing and long game today with no problems so far.
Platform used:
Vassal 3.4.10
MacOS Big Sur
iMac (27", mid-2020)
User avatar
marktb1961
 
Posts: 335
Joined: October 4th, 2018, 2:36 pm
Location: Liverpool, England

Re: What causes group select when dragging single piece?

Postby williamsbauer » October 12th, 2020, 11:16 pm

Just downloaded but haven't tried the release yet. For the curious among us - what was causing the issue?
williamsbauer
 
Posts: 2
Joined: April 11th, 2017, 12:15 am

Previous

Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 5 guests

cron