Create account / Log in

Text Labels

Issues with the Vassal engine.

Moderators: Tim M, uckelman

Text Labels

Postby Teufelhunde87 » January 9th, 2008, 9:25 pm

Been revamping my Gettysburg 77 module and am having trouble with my text labels not maitaining their aspect to to pieces assigned to. :? I didn't have any issues in my original release , though I did notice this happening sometimes while in the late development stages of my Close Assault/ Firepower module. I think a new Vassal version was released around then. Am I missing something or has anyone else experienced this?
thanks in advance
Greg
Teufelhunde87
 
Posts: 7
Joined: January 8th, 2008, 10:05 pm
Location: Pennsylvania

Postby bsmith » January 10th, 2008, 10:14 pm

I haven't noticed any problems myself; Have you tried changing the order of the piece traits?
User avatar
bsmith
Site Admin
 
Posts: 657
Joined: October 2nd, 2007, 4:47 pm

Postby Teufelhunde87 » January 10th, 2008, 10:31 pm

Yes, It is wierd. I have several text labels on my pieces for Close Assault/Firepower, and all worked well. Then I tried to add a text label to label specific wound damge, it won't maintain aspect. All others maintain. Then , I started reworking Gettysburg, and the first label I tried won't maintain, deleted several times and tried through prototyes and striaght into the piece. No avail....GGRRR!. I'll keep trying Close Assault turned out nice, I want to upgrade Gettysburg with what I learned. FRUSTRATING.
Teufelhunde87
 
Posts: 7
Joined: January 8th, 2008, 10:05 pm
Location: Pennsylvania

Postby Teufelhunde87 » January 10th, 2008, 10:51 pm

Okay, messed with it some more. Here is what I noticed. Piece has following properties: Can Rotate(R/L bracket keys w/ sub menu to turn), Move fixed distance-Line Form(NUMPAD7,9,1,3 w/ sub menu for move), Move fixed distance-column form(NUMPAD8,2 w/ submenu to move),Basic piece(no icon),Layer(6 layers, column, cav column,line,angle right,angle left, salient w/ dynamic prop to select w/ sub menu). If I put the piece on the board, enter strength value(text label bottom center), it is fine, formaion selcts fine still(layer). If I move piece , it is fine, when I turn the piece, depending on menu location of the can rotate and text label , I get one of two results...1) piece works fine, text label won't maintain aspect...2) text maitains aspect, piece will no longer cycle through the layers. Something seems to conflict with the label and the Can Rotate. Help any?
Teufelhunde87
 
Posts: 7
Joined: January 8th, 2008, 10:05 pm
Location: Pennsylvania

Postby Teufelhunde87 » January 10th, 2008, 11:04 pm

Alright, I ran with your location advice, maybe we got it, I have dynamic property 1st, text label 2nd,Can Rotate 3rd. VASSAL maybe needs to see the label and pieces first(?) before the can rotate command to enable all these things to work right? I noticed that I can also have inaccurate move commands if I use other positions. Like VASSAL only sees the initial piece placement? HMMM. Anyway, as of now, all of these are safely tucked away in this order in a prototype for all my formation pieces and so far I think everything works. Thanks for the advice.
Teufelhunde87
 
Posts: 7
Joined: January 8th, 2008, 10:05 pm
Location: Pennsylvania


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 1 guest