Create account / Log in

VASL Problem on MAC

Issues with the Vassal engine.

Moderators: Tim M, uckelman

VASL Problem on MAC

Postby MedievalBanquet » March 10th, 2008, 11:52 pm

I recently upgraded to the latest VASSAL version- I cleared my temp files in the Java area, etc. Now when I try to launch VASL 5.0.app icon I get :

Java Web Start - Invalid Argument Error


GENERAL
An error occurred while launching/running the application.

Category: Invalid Argument Error

Could not load file/URL specified: file://localhost/Users/YoungFamily/Libr ... vasl5.jnlp

EXCEPTION

(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at apple.launcher.LaunchRunner.run(LaunchRunner.java:115)
at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)

WRAPPED

(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at apple.launcher.LaunchRunner.run(LaunchRunner.java:115)
at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
MedievalBanquet
 
Posts: 6
Joined: March 10th, 2008, 11:48 pm

VASL Problem on MAC

Postby rk » March 11th, 2008, 12:01 am

I would expect clearing the temp file in Web Start to fix this, but if that doesn't help, you should try the manual installation.

rk

Post generated using Mail2Forum (http://www.mail2forum.com)
rk
Site Admin
 
Posts: 536
Joined: October 21st, 2007, 3:31 am

Postby MedievalBanquet » March 11th, 2008, 12:12 am

Hi, I've done both and it didn't work, sadly.


:D
MedievalBanquet
 
Posts: 6
Joined: March 10th, 2008, 11:48 pm

Now, I'm getting a similar error with VASSAL

Postby MedievalBanquet » March 11th, 2008, 12:22 am

An error occurred while launching/running the application.

Category: Invalid Argument Error

Could not load file/URL specified: file://localhost/Users/YoungFamily/Libr ... assal.jnlp

Is my Java stuff messed up?
MedievalBanquet
 
Posts: 6
Joined: March 10th, 2008, 11:48 pm

VASL Problem on MAC

Postby rk » March 11th, 2008, 7:01 pm

Could not load file/URL specified: [url=file:///Users/YoungFamily/Library/Caches/Java/cache/javaws/http/Dwww.vassalengine.org/P80/DMws/AMvassal.jnlp]file://localhost/Users/YoungFamily/Library/Caches/Java/cache/javaws/http/Dwww.vassalengine.org/P80/DMws/AMvassal.jnlp[/url]

This is an error from Java Web Start. It looks like one of the files that Web Start automatically downloads and stores has gone missing or corrupt. You can't get this error using the manual installer, because it doesn't use Web Start. If you want to try to make it work with Web Start, I suggest opening javaws and removing the VASSAL application. That should force it to re-download the bad file.

rk

Post generated using Mail2Forum (http://www.mail2forum.com)
rk
Site Admin
 
Posts: 536
Joined: October 21st, 2007, 3:31 am

Postby MedievalBanquet » March 11th, 2008, 10:58 pm

Cool, how about VASL not working?
MedievalBanquet
 
Posts: 6
Joined: March 10th, 2008, 11:48 pm


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 5 guests