Create account / Log in

Players using a router?

Issues with the Vassal engine.

Moderator: bsmith

Players using a router?

Postby lordnarvinye » February 13th, 2012, 7:31 pm

Allo all!

New to Vassal. Tried playing Advanced Civilization and Axis & Allies with a couple of old friends a few states away.

The problem was Vassal seemed to recognize both of them as the same player. In A&A whichever of them signed in last, that would be the side both of them played. Then one would have to resign that side (Ger) so that they could pick up the other side (Japan).

In Adv Civilization, they could both see each other's trade cards (which were hidden to me, as mine were hidden to them).

Best we could come up with was they were both operating from a router on the same IP, as they're room-mates in an apartment.

Is there a work-around for this? Or are we missing something completely?

Model: Home Built
OS: Win 7 x64 Pro
CPU: Intel Quad Core 3.0 GHz
Memory: 8GB
Video: ATI Radeon HD5870
VASSAL: 3.1.18
Java: 1.6.0_30
Module: Axis & Allis 1.0, Advanced Civilization 0.1

and thanks btw!! We were all just talking about "all we need is a virtual tabletop to play these great games we used to play together!"
lordnarvinye
 
Posts: 2
Joined: February 13th, 2012, 7:18 pm

Re: Players using a router?

Postby barbanera » February 13th, 2012, 7:35 pm

Were they using the same password?
barbanera
 
Posts: 346
Joined: January 12th, 2012, 2:27 pm

Re: Players using a router?

Postby mycenae » February 13th, 2012, 7:45 pm

Sounds like a password issue. Vassal links the side you're on to password, so every player must have a unique password. (Never use a password other players are likely to have, such as a variation of the game name.)

There's more about this in the user guide, on the Help menu.
mycenae
 
Posts: 391
Joined: May 16th, 2008, 6:41 pm

Re: Players using a router?

Postby lordnarvinye » February 13th, 2012, 8:01 pm

will take us a bit to test out, but that sounds like exactly what happened! thanks all.

and...duh
lordnarvinye
 
Posts: 2
Joined: February 13th, 2012, 7:18 pm


Return to Technical Support & Bugs

Who is online

Users browsing this forum: Google [Bot] and 2 guests