Create account / Log in

Tiling fails loading large JPEG map.

Issues with the Vassal engine.

Moderators: Tim M, uckelman

Tiling fails loading large JPEG map.

Postby Grognardo » November 6th, 2016, 5:45 pm

Hello.

I am making a module using Vassal version 3.2.16 for playtest of Thunder in the East, a monster WW2 boardgame, part of the European Theater of Operations series for Victory Point Games. One of the playtesters cannot load the module successfully, although two others report no problems, and I have installed and run it on three PCs with no problems. I've searched similar issues on this forum, but am at a loss at this point for things to change in the module or what to suggest to the user to circumvent the problem. This is my first foray into building a Vassal module.

The user reports that all components of the module appear to load correctly except the main map which is a large JPG. As best I can tell, the failure occurs at tiling. I've attached the error log from the user's installation (TiTE ErrorLog.txt), as well as that from a a successful run on my test bed PC (TestBed errorLog.txt), where I installed the same version of Java as the user (build 1.8.0_111-b14).

I'm revising the module for the next round of playtesting and I'd like to incude a fix for this problem in the next release. The current version can be downloaded from http://www.victorypointgames.com/documents/TiTE.vmod. Any advice from the Vassal devs or power users would be appreciated.

Thank you.
Ken Keller

TiTE ErrorLog.txt
ErrorLog when problem occurs
(4.88 KiB) Downloaded 189 times

TestBed errorLog.txt
ErrorLog for a successful load
(11.87 KiB) Downloaded 203 times
Grognardo
 
Posts: 5
Joined: November 6th, 2016, 4:59 pm

Re: Tiling fails loading large JPEG map.

Postby DrNostromo » November 8th, 2016, 3:46 pm

Try converting the map from .JPG to .PNG. Very large .JPG maps have been known to cause issues.
User avatar
DrNostromo
 
Posts: 1053
Joined: December 21st, 2007, 3:54 am
Location: Wine Country, Cal. USA

Re: Tiling fails loading large JPEG map.

Postby Grognardo » October 16th, 2017, 8:27 pm

A belated thanks to Dr. Nostromo. Converting to PNG solved the problem. Thought I would follow up in case someone with a similar problem searches the forum.

The map is quite large as a PNG (about 200M), so I break it up into 10 files which seems to speed up first-time loading.

Ken
Grognardo
 
Posts: 5
Joined: November 6th, 2016, 4:59 pm


Return to Technical Support & Bugs

Who is online

Users browsing this forum: jrwatts and 2 guests