Create account / Log in

Editor won't load extension when trying a game

Suggestions for additional features for the module editor and Vassal engine.

Moderators: uckelman, Tim M

Editor won't load extension when trying a game

Postby barbanera » December 19th, 2020, 1:14 pm

If I open an extension for editing and then launch "New game" for testing things out, everything is fine.

However, if I open the main module (with an extension attached) for editing and then launch "New game" for testing, then only the main module will be loaded. The extension does not seem to be loaded. Like it was not there.

In short, unless I am doing something wrong, there is no way to smoothly test updates to the main module, and how said updates might interplay with extension components, without having to close the editor, and reopen either the module in playing mode or the extension in editing mode. Then close, reopen the main module in editing mode etc etc.

Could it be possible to fix this for an upcoming 3.5.x version?
barbanera
 
Posts: 470
Joined: January 12th, 2012, 2:27 pm

Re: Editor won't load extension when trying a game

Postby Brent Easton » December 19th, 2020, 11:58 pm

Unfortunately, no, that is unlikely to change.

Editing a module specifically disables extension loading AND translation because the way they work interferes with the editing of the module.
User avatar
Brent Easton
 
Posts: 3318
Joined: December 21st, 2007, 3:06 am
Location: Berry, NSW, Australia


Return to Feature Requests

Who is online

Users browsing this forum: No registered users and 1 guest

cron