Create account / Log in

Does this sound familiar to anyone?

Discussion area for the development team.

Moderators: uckelman, Tim M

Does this sound familiar to anyone?

Postby Cattlesquat » July 21st, 2020, 3:11 am

Trying to get Vassal to run on a "MacOSX virtual machine". So a little non-standard obviously, but boy would it be useful if it would work.

So far:
(1) The "Mac" seems to work normally for the most part, but my max resolution is 1024x768.
(2) I can run Vassal (either 3.2.17 or 3.3.2), BUT... I normally can't get past the Module Manager.
(3) If I try pick "Open Module..." or "Edit Module..." nothing ever happens - no file menu to pick from, no nothing.
(4) BUT, if I pick "New Module", I get the Editor window with the new module and I can edit it -- and then I can run it and a Player window opens for that. But I can't really "Save" it because once again no file menu comes up if I hit "save as".

So I'm just wondering if anyone can think of a reason that a file window wouldn't open to pick a module to load in, as that's the only thing I can't seem to do.

Brian
User avatar
Cattlesquat
 
Posts: 941
Joined: December 2nd, 2019, 4:57 pm
Location: Baltimore, Maryland, USA

Re: Does this sound familiar to anyone?

Postby stew-rt » July 21st, 2020, 7:07 am

Do other native OS X apps open file -> open, file -> save as dialogues correctly?
OS X does have a mobile-like permissions framework if i recall correctly, perhaps the app doesn't have those. (.. though.. it should prompt you)

Every time I've tried to run "Hackintosh" VMs, they always act all stroppy and fail in weird ways
User avatar
stew-rt
 
Posts: 23
Joined: May 22nd, 2020, 8:27 am
Location: Cornwall, UK

Re: Does this sound familiar to anyone?

Postby stew-rt » July 21st, 2020, 8:00 am

I've just tested this on a Hackintosh VM, running in libvirt (I used this firmware, etc https://github.com/foxlet/macOS-Simple-KVM).
Running OS X Catilana..

I had to go through the process of unblocking it from the OS's "malware prevention" to get it to open, but then I was able to open the app, and the File -> Load Dialog loads a module fine (my god Java GUI decoration is UGLY on OS X.. I thought it was naff on Linux, but at least they do GTK decoration now..).

In saying this, I had to do similar confirming that I do, indeed want to run this application when I was testing in Windows 10 the other day.

Perhaps an Issue should be opened to do whatever it is that needs to be done to sign these installers at some point?

It doesn't appear to work properly if I double click on the module, though. It just puts a new VASSAL icon in the "recents" part of the dock.. and doesn't seem to do anything.
User avatar
stew-rt
 
Posts: 23
Joined: May 22nd, 2020, 8:27 am
Location: Cornwall, UK

Re: Does this sound familiar to anyone?

Postby uckelman » July 21st, 2020, 12:26 pm

Thus spake stew-rt:
>
> Perhaps an Issue should be opened to do whatever it is that needs to be
> done to sign these installers at some point?
>

See here for a discussion of that point:

viewtopic.php?f=5&t=12142

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8980
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Does this sound familiar to anyone?

Postby Cattlesquat » July 21st, 2020, 3:25 pm

Here is what errorLog looks like

Vengine.jar!/images/
2020-07-20 20:12:25,362 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family go-down created for go-down.png
2020-07-20 20:12:25,363 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family VASSAL created for VASSAL.png
2020-07-20 20:12:25,363 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family go-up created for go-up.png
2020-07-20 20:12:25,363 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family VASSAL-jabber created for VASSAL-jabber.png
2020-07-20 20:12:25,363 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family no created for no.png
2020-07-20 20:12:25,363 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family calculator created for calculator.png
2020-07-20 20:12:25,363 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family yes created for yes.png
2020-07-20 20:12:25,363 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family network-server created for network-server.png
2020-07-20 20:12:25,363 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family network-idle created for network-idle.png
2020-07-20 20:12:25,363 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family bug created for bug.png
2020-07-20 20:12:25,363 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family jabber created for jabber.png
2020-07-20 20:12:26,782 [1-AWT-EventQueue-0] WARN VASSAL.launch.BasicModule - Unnamed module version 0.0
2020-07-20 20:12:40,313 [0-ProcessLauncher-2] WARN VASSAL.tools.logging.LoggedOutputStream - 2020-07-20 20:12:40.313 java[1921:11702] +[NSXPCSharedListener endpointForReply:withListenerName:]: an error occurred while attempting to obtain endpoint for listener 'com.apple.view-bridge': Connection interrupted
2020-07-20 20:12:58,905 [0-ProcessLauncher-2] WARN VASSAL.tools.logging.LoggedOutputStream - 2020-07-20 20:12:58.905 java[1921:11553] +[NSXPCSharedListener endpointForReply:withListenerName:]: an error occurred while attempting to obtain endpoint for listener 'com.apple.view-bridge': Connection interrupted
2020-07-20 20:13:14,549 [0-ProcessLauncher-2] WARN VASSAL.tools.logging.LoggedOutputStream - 2020-07-20 20:13:14.548 java[1921:11775] +[NSXPCSharedListener endpointForReply:withListenerName:]: an error occurred while attempting to obtain endpoint for listener 'com.apple.view-bridge': Connection interrupted
User avatar
Cattlesquat
 
Posts: 941
Joined: December 2nd, 2019, 4:57 pm
Location: Baltimore, Maryland, USA

Re: Does this sound familiar to anyone?

Postby uckelman » July 21st, 2020, 11:46 pm

Thus spake Cattlesquat:
> VASSAL.tools.logging.LoggedOutputStream - 2020-07-20 20:12:40.313
> java[1921:11702] +[NSXPCSharedListener
> endpointForReply:withListenerName:]: an error occurred while attempting
> to obtain endpoint for listener 'com.apple.view-bridge': Connection
> interrupted
> 2020-07-20 20:12:58,905 [0-ProcessLauncher-2] WARN
> VASSAL.tools.logging.LoggedOutputStream - 2020-07-20 20:12:58.905
> java[1921:11553] +[NSXPCSharedListener
> endpointForReply:withListenerName:]: an error occurred while attempting
> to obtain endpoint for listener 'com.apple.view-bridge': Connection
> interrupted
> 2020-07-20 20:13:14,549 [0-ProcessLauncher-2] WARN
> VASSAL.tools.logging.LoggedOutputStream - 2020-07-20 20:13:14.548
> java[1921:11775] +[NSXPCSharedListener
> endpointForReply:withListenerName:]: an error occurred while attempting
> to obtain endpoint for listener 'com.apple.view-bridge': Connection
> interrupted

That's a new one for me. It's some sort of OS X internal error, though.

Looks a lot like this:

https://bugs.openjdk.java.net/browse/JDK-8227836

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8980
Joined: December 10th, 2007, 9:48 am
Location: Durham, England


Return to Developers

Who is online

Users browsing this forum: No registered users and 2 guests