Create account / Log in

Preparing for 3.2.0-beta1

Discussion area for the development team.

Moderator: bsmith

Preparing for 3.2.0-beta1

Postby uckelman » May 18th, 2012, 5:12 am

There are no longer so many critical bugs left on the list for 3.2.0, so I'd like to start getting a wider audience for our 3.2.0 builds. This means gearing up for releasing 3.2.0-beta1.

That said, are there any bugs remainging on the list for 3.2.0 which anyone believes absolutely has to be resolved before beta1?

http://www.vassalengine.org/tracker/bug ... tone=3.2.0

Or, are there any bugs not listed here which should be?
User avatar
uckelman
Site Admin
 
Posts: 6882
Joined: December 10th, 2007, 9:48 am
Location: Heidelberg, DE

Re: Preparing for 3.2.0-beta1

Postby mroyer » May 18th, 2012, 10:13 pm

Importance is in the eye of the beholder ;)

For me, 4122 (topping the buglist) is a show stopper. I can't play my module until it's fixed. I've been using a build from last November (build 7890), which is the last build my module worked on. I think it would be useful to have me testing the latest builds since my module is very stressful to VASSAL and is likely to vet out some unusual cases.

-Mark R.
mroyer
 
Posts: 159
Joined: March 4th, 2011, 5:06 pm
Location: Massachusetts

Re: Preparing for 3.2.0-beta1

Postby uckelman » May 18th, 2012, 10:22 pm

Thus spake mroyer:
> Importance is in the eye of the beholder ;)
>
> For me, 4122 (topping the buglist) is a show stopper. I can't play my
> module until it's fixed. I've been using a build from last November
> (build 7890), which is the last build my module worked on. I think it
> would be useful to have me testing the latest builds since my module is
> very stressful to VASSAL and is likely to vet out some unusual cases.

Can you build us a minimal example which triggers the bug?

--
J.
User avatar
uckelman
Site Admin
 
Posts: 6882
Joined: December 10th, 2007, 9:48 am
Location: Heidelberg, DE

Re: Preparing for 3.2.0-beta1

Postby mroyer » May 19th, 2012, 2:00 am

I'll try - perhaps tomorrow morning (EST)
mroyer
 
Posts: 159
Joined: March 4th, 2011, 5:06 pm
Location: Massachusetts

Re: Preparing for 3.2.0-beta1

Postby mroyer » May 19th, 2012, 11:24 am

uckelman wrote:Can you build us a minimal example which triggers the bug?

--
J.



This minimized module exhibits the problem - it only contains a single map section (Map 1) and a single counter. It's about 13 MB almost all of which is the map image.
http://dl.dropbox.com/u/24119799/WAAM1

If I run the above module with build 7890 (on Windows 7), the map hexgrid appears fine and the counters snap t the grid as designed. If I run it on build 8171, I get an "eek" bug at start-up (I think after the splash screen). Clicking past the bug and continuing, the hexgrid is not shown on the map and counters do not snap to it, as though the grid were not there at all. (indeed, if I save the module with 8171, the grid is lost, even if I go back to 7890, which may be a clue.)

BTW, I think build 8174 for windows is messed up - it won't execute.

Thanks J.!! for all the work you do for VASSAL - we really appreciate it.

-Mark R.
mroyer
 
Posts: 159
Joined: March 4th, 2011, 5:06 pm
Location: Massachusetts

Re: Preparing for 3.2.0-beta1

Postby uckelman » May 21st, 2012, 11:01 pm

Thus spake mroyer:
>
> This minimized module exhibits the problem - it only contains a single
> map section (Map 1) and a single counter. It's about 13 MB almost all
> of which is the map image.
> http://dl.dropbox.com/u/24119799/WAAM1[1]

In what version of VASSAL was this module originally created? I can't
find anything in 3.1 which would write an attribute called snapTo. I
think what's happening is that HexGrid in 3.1 silently ignores
attributes it doesn't recognize, while HexGrid in 3.2 throws an
exception.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 6882
Joined: December 10th, 2007, 9:48 am
Location: Heidelberg, DE

Re: Preparing for 3.2.0-beta1

Postby uckelman » May 22nd, 2012, 2:22 am

Thus spake mroyer:
>
> If I run the above module with build 7890 (on Windows 7), the map
> hexgrid appears fine and the counters snap t the grid as designed. If I
> run it on build 8171, I get an "eek" bug at start-up (I think after the
> splash screen). Clicking past the bug and continuing, the hexgrid is
> not shown on the map and counters do not snap to it, as though the grid
> were not there at all. (indeed, if I save the module with 8171, the
> grid is lost, even if I go back to 7890, which may be a clue.)

Does the svn8175 build work better for you?

The problem is that Pieter's changes and additions to the code dealing
with grids cause IllegalArgumentExceptions when HexGrid encounters an
unrecognized attribute. As it's all rather tangly and doesn't handle
exceptions properly, it not easy for me to fix, so I've reverted it for
now. If Pieter wants to revisit it when he has some time to fix these
problems, I'll be happy to consider re-merging it.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 6882
Joined: December 10th, 2007, 9:48 am
Location: Heidelberg, DE

Re: Preparing for 3.2.0-beta1

Postby mroyer » May 22nd, 2012, 3:46 am

Thanks Joel, I'll give this a go tomorrow morning. The module is in development, so I edit and save it frequently in 3.2. I think it was originally built on a version of 3.1 (maybe 3.1.6). No idea when a "snap-to" might have crept in.
mroyer
 
Posts: 159
Joined: March 4th, 2011, 5:06 pm
Location: Massachusetts

Re: Preparing for 3.2.0-beta1

Postby mroyer » May 22nd, 2012, 4:00 am

Excellent Joel! It appears to be working again in 8175, at least at quick glance tonight. I will give it more checkout tomorrow morning, and my playtest group gets together again on Wednesday evening - so it will see more thorough action then.

I appreciate all the hard work you guys do here!!

-Mark R.
mroyer
 
Posts: 159
Joined: March 4th, 2011, 5:06 pm
Location: Massachusetts

Re: Preparing for 3.2.0-beta1

Postby Rindis » May 23rd, 2012, 3:46 pm

I was just finding last night that the F&E module still had some minor positioning errors in svn8170 (a couple of pixels of drift, stacking issues, etc). 8175 seems to have sorted all that out, so the the reversion is good. :P
User avatar
Rindis
 
Posts: 142
Joined: December 22nd, 2007, 12:49 am


Return to Developers

Who is online

Users browsing this forum: No registered users and 1 guest