Page 1 of 1

Weird problem with module

PostPosted: September 29th, 2013, 2:02 am
by briareos
Ok I'm working on a pathfinder module that someone else was working on and they wanted to share with me. When you flip over a card face down as soon as you click to drag it it flips face up and then when you click outside the card it flips back face down. I'm sure there's a way to fix that?

Re: Weird problem with module

PostPosted: September 29th, 2013, 4:35 am
by capi3101
I'd have to see how the cards were designed to diagnose the problem - I know with KCP, the visible/masked state of a card stays the same when you move it around on a board or between boards, and the cards in that mod are probably as vanilla as you can get for most card games (A Basic Piece Trait for the front, a Mask Trait for the back with commands to flip the card over, and a Return to Deck trait for discarding).

That's probably a place to start; do the cards in the mod have any other traits?

Re: Weird problem with module

PostPosted: September 29th, 2013, 12:59 pm
by Tim M
You are describing the peek behavior, remove the peek command on the mask trait.

Re: Weird problem with module

PostPosted: September 30th, 2013, 1:20 am
by Brent Easton
And it is only you (the 'owner' or person who flipped it over) who sees the card face up when you click on it, no one else. Reed up on the Peek behavior, it has a number of settings that control how you see your own cards when they are face down.

Re: Weird problem with module

PostPosted: September 30th, 2013, 2:01 pm
by capi3101
These gentlemen know what they're talking about; not a part of the Mask Trait I've ever used my own self, which is why I didn't know (sounds handy though - I can think of an immediate application for my Armada PNP mod). I got to learn something today...

Briareos, if you want to shut that feature off, you'll need to go the affected Decks and select "Edit All Contained Pieces". Open the Mask Trait properties and go to the bottom image. There should be a drop down Menu item that says "Plain"; you can change that to another option or there should be a checkbox or radio button there marked "Peek" that's selected, unselect it and hit okay.

Personally, I could see some value in leaving that feature in, but it's your mod (received your PM and downloaded the mod file, BTW).