Page 1 of 1

Any fix for the tiny font issue?

PostPosted: February 13th, 2019, 7:09 am
by Heera
I just got a laptop with windows 10. vassal needs java to run. got that and it loads, but the font is super small. from the vassal forums, some people mention a fix with other users saying they don't work.

Is there anything definitive out there solution wise?

Thanks

Re: Any fix for the tiny font issue?

PostPosted: March 4th, 2019, 8:35 pm
by zgrose
I've had luck with High DPI support in Java with the most recent OpenJDK but you may encounter other, module-specific, issues.

Re: Any fix for the tiny font issue?

PostPosted: March 4th, 2019, 11:23 pm
by jimpyle
Some posted this over on ConsimWorld I think:

For Win 10 users the fix is this:

1. Right click on the VASSAL icon, then click More -> Open File Location, which opens a file explorer window containing the actual VASSAL shortcut.

2. Right click on the shortcut, then click Properties from the context menu.

3. In the properties window click the Compatibility tab.

4. Check the box for "Override high DPI scaling behavior"

5. In the Scaling performed by drop down list, select "System."

6. Save the settings and launch VASSAL.

7. Enjoy the nice legible app we all know and love

Re: Any fix for the tiny font issue?

PostPosted: March 25th, 2019, 10:14 pm
by Cundiff
What do you do for Win 7 users?

Re: Any fix for the tiny font issue?

PostPosted: March 26th, 2019, 5:33 pm
by DrNostromo
The Win 7 shortcut properties has the same options so I would assume that method would work on Win 7, as well. Let us know if it does.

Re: Any fix for the tiny font issue?

PostPosted: March 28th, 2019, 12:41 am
by Cundiff
Check the box for "Override high DPI scaling behavior"

This doesn't exist in my Win7 window.

Re: Any fix for the tiny font issue?

PostPosted: March 28th, 2019, 5:53 pm
by DrNostromo
I have a Win 7 SP1 laptop 64bit.

I have a shortcut to Vassal 3.2.17

If I right-click that shortcut, go to Properties and click the Compatibility tab, the "Disable display scaling on high DPI settings" is right there at the bottom of the Settings list.

If you don't have that option, it may be possible that this is an Administrator option. Are you logged on as an Administrator?

Re: Any fix for the tiny font issue?

PostPosted: March 28th, 2019, 5:58 pm
by JoelCFC25
Probably expecting to see it on the shortcut and isn't looking at the properties of the executable itself.

Re: Any fix for the tiny font issue?

PostPosted: March 28th, 2019, 6:02 pm
by DrNostromo
I checked that and for me, the options on both the .exe and the shortcut. Of course, I haven't tried either one as I don't have a font issue so I don't know if it works or not.

Re: Any fix for the tiny font issue?

PostPosted: April 24th, 2019, 3:04 pm
by Badger16
I checked on my computer, and it works.