Create account / Log in

Other player can't activate tiles

Topics related to Vassal game modules.

Moderators: uckelman, Tim M

Other player can't activate tiles

Postby starfish » May 19th, 2016, 12:43 pm

I have a really weird problem with Burgle Bros. (I created the module) that I can't figure out. The game has tiles that you can select with SHIFT-CLICK. once selected, any player should be able to activate one of two functions - Move into tile (CTRL Y) or Peek into Tile (CTRL T). Both do essentially the same thing - unmask the tile and report the action. Since this is a coop game, I did not intentionally try to prevent anyone from doing anything. Everything works great when I test solo. When I join an Internet game, one player or the other (it is not the same each time) becomes the "master" and can activate tiles, and the other player cannot. I had a feature I put in for testing that provided activation of the trait "RETURN TO DECK". I have noticed that the player that is not the master does not have this trait show up when they shift-click the tile.

Any ideas how to track this down? Is there a variable I can expose (and possibly change) that says who can flip a tile? If I can see "who has control" and provide a control to change this to the next player, fine. But right now it sort of guessing game as to who can flip a tile.

Thanks for any feedback!
starfish
 
Posts: 26
Joined: April 13th, 2013, 6:25 pm

Re: Other player can't activate tiles

Postby DrNostromo » May 19th, 2016, 2:56 pm

Are you sure you have the setting "Can be masked by - Any Player" set in your Mask trait?
User avatar
DrNostromo
 
Posts: 1073
Joined: December 21st, 2007, 3:54 am
Location: Wine Country, Cal. USA

Re: Other player can't activate tiles

Postby starfish » May 20th, 2016, 3:32 am

I liked the suggestion, as I feel it might be something like this that I have overlooked. Unfortunately, the Mask trait is set to "Any Player". I tried to set it to "Any Side" to see if behavior changed, but no luck. I have also added a trait "Restrict Access" and put everyone side (Player 1, Player 2, Player 3, and Player 4) on the list. This didn't work either. I can definately say the person who deals the cards is the only one who can mask them.
starfish
 
Posts: 26
Joined: April 13th, 2013, 6:25 pm

Re: Other player can't activate tiles

Postby starfish » May 20th, 2016, 3:59 am

Further weirdness - If the "Dealer" masks a card, then the other player can sometimes mask and unmask it! Tried changing the deal global command to only run 16 times, versus for every card. Still no luck.
starfish
 
Posts: 26
Joined: April 13th, 2013, 6:25 pm

Re: Other player can't activate tiles

Postby shilinski » May 31st, 2016, 1:38 am

It sounds like you don't understand how masking works. If you mask a piece, then Vassal says you control it. For example, if you draw a card face-down or flip a card face-down, you now own that card. Vassal registers it to you by stamping it internally with your Vassal password. As owner (and depending how the module designer set it up), your card on the Vassal table in front of you may appear face-up, but it appears face-down to your opponents. Only you can turn it face-up. You can peek at it; they can't. If it's face-down, then only you can see its traits that are arranged above it in the trait list (like the send-to-deck command, which you mentioned). Masking is a great feature in block games and card games. Bad for you is you can't disable this behavior. But there are 2 things I can think of that let's you maybe get around it.

First, if you really don't need masking's ownership features, you may be able to model it using the Layer trait. Note that there are two Layer features in Vassal. The one you want is the piece trait and not the one you see in Maps. (Although it's important too, and you should know what it does.)

The second thing you can do is "allow opponents to unmask my pieces." This won't fix all your problems, but it could help. This lets other player flip face-up your face-down pieces. It's a very helpful feature when pbem. Open your module and do File / Preferences / General. It's a checkbox there. There is no way I know of to turn it on automatically. Each player must do it manually in every module where they need it. It's off by default. (In one of your statements, it sounds like one of your players had it enabled.)
shilinski
 
Posts: 196
Joined: December 22nd, 2007, 8:46 am
Location: Laurel, Maryland


Return to Module General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests