Create account / Log in

Log in problems on new forum

Topics related to the main Vassal engine.

Moderators: uckelman, Tim M

Re: [messages] [General Discussion] Re: Log in problems on n

Postby uckelman » July 26th, 2010, 9:56 pm

Thus spake Richz99:
> Yesterday, all was good. Today I couldn't log in at all (until I tried
> to reply to this post and the "other" log-in screen came up).
>

I'm going to be removing that way of logging in soon. If you're still
having problems, then I need you to email me your username and password
so I can troubleshoot.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8849
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Log in problems on new forum

Postby MadSeason » July 27th, 2010, 3:50 pm

I sent you a PM, Uckelman, hoping for some help. Right now, the only way I can log in is by replying to a forum message.

Thank you in advance.
User avatar
MadSeason
 
Posts: 64
Joined: February 9th, 2008, 2:24 pm

Re: [messages] [General Discussion] Re: Log in problems on n

Postby uckelman » July 27th, 2010, 6:43 pm

Thus spake MadSeason:
> I sent you a PM, Uckelman, hoping for some help. Right now, the only way
> I can log in is by replying to a forum message.
>

I'm replying here with the same thing I said in the PM:

I can't reproduce this. When I log in as you, it works fine for me.

Are you behind a caching proxy? What happens if, when you see a page which
says you're not logged in when you expect to be, you force the page to
reload?

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8849
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Log in problems on new forum

Postby MadSeason » July 27th, 2010, 7:11 pm

I don't know what to say. It seems to be working right now. I just navigated all over the site and stayed logged in. That wasn't like that before...

I did try opening another window and being logged in in two different windows. It's not a huge deal, but I was unable to log in in the second window while remaining logged in in the first window.

I'll be in touch if it stops working. :D

Thank you for looking into it.
User avatar
MadSeason
 
Posts: 64
Joined: February 9th, 2008, 2:24 pm

Re: Log in problems on new forum

Postby Richz99 » July 27th, 2010, 8:51 pm

I tried refreshing the page when I was having the problem... No luck.

All's good today. Hopefully tomorrow's the same.
Rich Lee
User avatar
Richz99
 
Posts: 76
Joined: November 22nd, 2009, 12:12 am

Re: Log in problems on new forum

Postby uckelman » July 29th, 2010, 10:46 am

If you're logged in, but then your browse to another page where it says you're not logged in, please check the URL of the not-logged-in page. I have a suspicion that the domain will be vassalengine.org instead of www.vassalengine.org. The next time this happens for you, check the URL and let me know whether my suspicion was right.

If this is happening for you, it's due to the domain specified for the site cookies. The site cookies are all for the www.vassalengine.org domain, so if you go to vassalengine.org without "www", the relevant cookies aren't presented to the web server. I'm looking into whether I should (1) remove the "www" from the cookie domain, (2) redirect vassalengine.org to www.vassalengine.org, (3) redirect www.vassalengine.org to vassalengine.org and remove the "www" from the cookie domain, or (4) something else.
User avatar
uckelman
Site Admin
 
Posts: 8849
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Log in problems on new forum

Postby uckelman » July 29th, 2010, 8:54 pm

Also, if you're having login problems, try deleting all of the cookies your browser has from vassalengine.org. I just corrected a small problem with the way cookies are sent, which might make a difference for logging in.
User avatar
uckelman
Site Admin
 
Posts: 8849
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Log in problems on new forum

Postby llkojnjhfy » June 10th, 2011, 1:57 am

uckelman whatever you did does seem to have fixed the problem. I can now log in and access all areas. :lol:
llkojnjhfy
 
Posts: 1
Joined: June 10th, 2011, 1:56 am

Previous

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron