Create account / Log in

mac zipped files not recognized

Issues with the Vassal engine.

Moderators: Tim M, uckelman

mac zipped files not recognized

Postby paul88 » July 20th, 2011, 7:20 am

First off I'm working on a imac G5 running osx 10.5.8

I unzipped a mod I'm working on to get rid of some images that I changed and when I re-zipped it and renamed it to .vmod vassal would no longer recognize it.

I get this error '/Users/paul/Desktop/High_Fantasy.vmod' is not a valid VASSAL module.

Now I'm thinking that it's because the mac archive feature uses some extra meta data than the standard pc zip and this may be the problem.

I tried using yemuzip which is supposed to get rid of this extra meta data but had the same result.

Does anybody know anything about this ?

Is there a workaround ?

Am I off base and this is not the actual problem ?

Or do I need to throw it on a thumbdrive and run across town and do it on a friends pc ?

Thanks for any help.
paul88
 
Posts: 10
Joined: February 18th, 2011, 4:23 pm

Re: mac zipped files not recognized

Postby Brent Easton » July 20th, 2011, 11:46 am

Most likely you have rezipped the files at the wrong level. Look inside the new module file you are creating. Do you see a buildfile and an images directory (correct), or do you see a Folder that contains a buildfile and an images directory (incorrect).
User avatar
Brent Easton
 
Posts: 2757
Joined: December 21st, 2007, 3:06 am
Location: Berry, NSW, Australia

Re: mac zipped files not recognized

Postby mycenae » July 20th, 2011, 2:46 pm

There are some detailed instructions for removing unneeded files from a module in this thread. They're Mac-centric, but the procedure is the same on any platform.

viewtopic.php?f=6&t=3877&hilit=level+archive
mycenae
 
Posts: 392
Joined: May 16th, 2008, 6:41 pm

Re: mac zipped files not recognized

Postby paul88 » July 20th, 2011, 3:05 pm

OK I see what I was doing.

Now that my head is removed from my butt everything works.

Thanks for the help guys. :D
paul88
 
Posts: 10
Joined: February 18th, 2011, 4:23 pm


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 0 guests