Create account / Log in

Hmm, Moving counter oddness?

Topics related to the main Vassal engine.

Moderators: uckelman, Tim M

Hmm, Moving counter oddness?

Postby Totalgit » November 7th, 2011, 1:20 pm

Ive just upgraded from windows xp to windows 7 and after sorting out a small niggle with java versions im just wondering if i am imaging something i think has changed.

When i select and move a counter/card, it vanishes and a faded/ghosty appears some distance away to the bottom right. I'm left with a little hand pointer and the piece gets placed where i move the hand too.

My problem is the distance the faded/ghost image depends on what position i click on the counter, if i click on the bottom right of a card then its faded image is furthest away from the hand shaped mouse pointer, and if i click at the top left of a card its closest to where the counter really is.

Is there a preference option or somthing so that when i move a peice and want to place it somewhere its placed where the ghost image is and not where the pointer is?

I understand this might be due to new resolution or something and its not a game breaker, though it might be annoying when trying to line up cards/counters properly since i cant see where theyd be placed exactly before hand.
Totalgit
 
Posts: 9
Joined: October 9th, 2011, 3:08 pm

Re: Hmm, Moving counter oddness?

Postby Totalgit » November 7th, 2011, 1:47 pm

heres a screenshot to explain what i mean, i clicked on the lower right corner of the card and moved my mouse to the black circle position but the image of the card is above the leadership deck. The card would end up with its lower right corner where the black circle is and the rest of the card would be above it out of shot.

Image

Uploaded with ImageShack.us
Totalgit
 
Posts: 9
Joined: October 9th, 2011, 3:08 pm

Re: Hmm, Moving counter oddness?

Postby Brent Easton » November 7th, 2011, 8:05 pm

Ok, so the drag and drop positioning is working correctly, but the Drag Cursor is in the wrong place.

Does the ghost image move as you drag the cursor, or does it stay stuck in the same place?

Are there any other Windows 7 users experiencing similiar problems?

Exactly what version of Java are you using? Could you please post the errorlog file (In Module Manager, Help -> Show Error Log).

Thanks,
Brent.
User avatar
Brent Easton
 
Posts: 3090
Joined: December 21st, 2007, 3:06 am
Location: Berry, NSW, Australia

Re: Hmm, Moving counter oddness?

Postby Totalgit » November 8th, 2011, 4:10 am

The ghost image moves when you move the cursor ok, its just abit far from the actual mouse pointer depending on where you pick the card/counter from.

Heres the error log
Code: Select all
08 Nov 2011 04:06:31.631 0 -- Starting
08 Nov 2011 04:06:31.633 0 -- OS Windows 7
08 Nov 2011 04:06:31.633 0 -- Java version 1.7.0
08 Nov 2011 04:06:31.633 0 -- VASSAL version 3.1.17
08 Nov 2011 04:06:31.675 0 -- Manager
08 Nov 2011 04:07:01.351 0 -- Loading module file C:\Program Files (x86)\VASSAL\Modules\Battlestar_Galactica_FFG_156.vmod
08 Nov 2011 04:07:01.352 0 -- Loading module Battlestar Galactica FFG
08 Nov 2011 04:07:01.355 0 C:\Program Files\Java\jre7\bin\java -Xms256M -Xmx512M -DVASSAL.id=1 -Duser.home=C:\Users\Bryan -cp lib\Vengine.jar VASSAL.launch.Player
08 Nov 2011 04:07:04.200 1 -- Battlestar Galactica FFG version 1.5.6
08 Nov 2011 04:07:04.201 1

08 Nov 2011 04:07:04.223 1 -- Loading extension C:\Program Files (x86)\VASSAL\Modules\Battlestar_Galactica_FFG_156_ext\Battlestar_Exodus_113.vmdx
08 Nov 2011 04:07:04.303 1 -- Extension Battlestar_Exodus_113 v1.1.3 loaded
08 Nov 2011 04:07:04.303 1

08 Nov 2011 04:07:04.303 1 -- Loading extension C:\Program Files (x86)\VASSAL\Modules\Battlestar_Galactica_FFG_156_ext\Battlestar_Exodus_CylonFleet_104.vmdx
08 Nov 2011 04:07:04.346 1 -- Extension Battlestar_Exodus_CylonFleet_104 v1.0.4 loaded
08 Nov 2011 04:07:04.346 1

08 Nov 2011 04:07:04.346 1 -- Loading extension C:\Program Files (x86)\VASSAL\Modules\Battlestar_Galactica_FFG_156_ext\Battlestar_Pegasus_1561.vmdx
08 Nov 2011 04:07:04.450 1 -- Extension Battlestar_Pegasus_1561 v1.5.6.1 loaded
08 Nov 2011 04:07:04.450 1


Dont think anything bad is going on from it but then im no expert, from it you can see im using 1.7.0 java x64, i did try version 6 update 29 but had other problems that moving to 1.7.0 fixed.
Totalgit
 
Posts: 9
Joined: October 9th, 2011, 3:08 pm

Re: Hmm, Moving counter oddness?

Postby Totalgit » November 8th, 2011, 6:40 am

Well, dont i feel abit silly, seems the problem is with using java 1.7.0 and before that i was probably using the 32bit version of java.

I uninstalled 1.7.0 and installed 1.6.0_29 x64 bit and everything seems to be as it was, ie fine.

So yeh, The correct Java version is pretty important. Thanks for the reply.
Totalgit
 
Posts: 9
Joined: October 9th, 2011, 3:08 pm

Re: Hmm, Moving counter oddness?

Postby irishwulf » January 1st, 2012, 1:31 am

I am also having this exact problem on Win7 + Java 1.7.0_02 + Vassal 3.1.17. As Totalgit suggests, the problem started immediately after updating to 1.7.0 (or rather, after having an update thrust upon me). But yes, the positioning is working correctly, so it is a minor annoyance.
In the meantime, perhaps you developer types can clue me in on why Vassal insists on running with 1.7.0 - I have set JAVA_HOME, copied my old java.exe and javaw.exe to system32, and disabled the 1.7.0 references in the Java runtime environment settings in my control panel. "Java -version" from a command prompt gives me 1.6.0_30. What am I missing?
irishwulf
 
Posts: 243
Joined: December 17th, 2011, 4:29 am

Re: [messages] [General Discussion] Re: Hmm, Moving counter

Postby uckelman » January 1st, 2012, 9:47 pm

Thus spake irishwulf:
> I am also having this exact problem on Win7 + Java 1.7.0_02 + Vassal
> 3.1.17. As Totalgit suggests, the problem started immediately after
> updating to 1.7.0 (or rather, after having an update thrust upon me).
> But yes, the positioning is working correctly, so it is a minor
> annoyance.

The behavior of something in Java changed from 1.6 to 1.7. It could be
a Java bug, it could be a documented change, it could be that we were
relying on a behavior which wasn't required by the API which has since
changed.

> In the meantime, perhaps you developer types can clue me in on why
> Vassal insists on running with 1.7.0 - I have set JAVA_HOME, copied my
> old java.exe and javaw.exe to system32, and disabled the 1.7.0
> references in the Java runtime environment settings in my control panel.
> "Java -version" from a command prompt gives me 1.6.0_30. What am I
> missing?

Try running the batch file which ships with VASSAL. Does that run with
Java 1.6? If so, then the executable which normally launches VASSAL is
what's finding Java 1.7, possibly from something in the Windows
registry.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8798
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Hmm, Moving counter oddness?

Postby irishwulf » January 3rd, 2012, 3:39 am

As always, Joel, thank you for the quick reply. I ended up uninstalling 1.7, though I first tried manually switching all the registry entries to my 1.6 installation with no luck. I'll keep the batch file in mind if I have the bad judgment to reinstall 1.7 in the future.

Mostly, I just wanted to reinforce that the DragCursor behavior is reproducible.

Cheers,
Seth
irishwulf
 
Posts: 243
Joined: December 17th, 2011, 4:29 am

Re: Hmm, Moving counter oddness?

Postby uckelman » January 13th, 2012, 11:11 pm

I've noted this as Bug 4202 in our tracker.
User avatar
uckelman
Site Admin
 
Posts: 8798
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Hmm, Moving counter oddness?

Postby uckelman » January 13th, 2012, 11:12 pm

uckelman wrote:I've noted this as Bug 4204 in our tracker.
User avatar
uckelman
Site Admin
 
Posts: 8798
Joined: December 10th, 2007, 9:48 am
Location: Durham, England


Return to General Discussion

Who is online

Users browsing this forum: fcolmenarez and 1 guest