Create account / Log in

Build 3.2 - Mouse Over Viewer Problem

Issues with the Vassal engine.

Moderators: uckelman, Tim M

Build 3.2 - Mouse Over Viewer Problem

Postby DrNostromo » November 20th, 2011, 12:25 am

I ran across a weird anomaly when I was playtesting my current build of To Be King.

During the character creations process, a player selects a race for their character. The game then sets up the character and places a token for the player on the board. Now if I hold the mouse over the token without selecting it, the mouse over viewer shows me the player's token and the terrain tile it's sitting on (which is what it's supposed to do), like this:

Image

However, when I moved the piece to a different location, the mouse over viewer will now only display the token and won't display the terrain tile underneath it - although it will still display the terrain tile name - like this:

Image

Here's my mouse over viewer settings for this map window:

Image

Also, I should point out that each hex has been set up as a zone. I don't know if that applies but I thought I should point that out.
User avatar
DrNostromo
 
Posts: 1061
Joined: December 21st, 2007, 3:54 am
Location: Wine Country, Cal. USA

Re: Build 3.2 - Mouse Over Viewer Problem

Postby uckelman » March 4th, 2012, 4:35 pm

Thus spake DrNostromo:
> I ran across a weird anomaly when I was playtesting my current build of
> To Be King.
>
> During the character creations process, a player selects a race for
> their character. The game then sets up the character and places a token
> for the player on the board. Now if I hold the mouse over the token
> without selecting it, the mouse over viewer shows me the player's token
> and the terrain tile it's sitting on (which is what it's supposed to
> do), like this:
>
> [1]
>
> However, when I moved the piece to a different location, the mouse over
> viewer will now only display the token and won't display the terrain
> tile underneath it - although it will still display the terrain tile
> name - like this:
>
> [2]
>
> Here's my mouse over viewer settings for this map window:
>
> [3]
>
> Also, I should point out that each hex has been set up as a zone. I
> don't know if that applies but I thought I should point that out.
>
> [1] http://drnostromo.com/MOVAnom1.png
> [2] http://drnostromo.com/MOVAnom2.png
> [3] http://drnostromo.com/MOVAnom3.png

Does this happen with current 3.2 builds? If so, can you create a
minimal example which demonstrates it?

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8798
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Build 3.2 - Mouse Over Viewer Problem

Postby DrNostromo » March 5th, 2012, 4:02 pm

I'll look into it but I probably won't have time till Wednesday. I'll let you know.
User avatar
DrNostromo
 
Posts: 1061
Joined: December 21st, 2007, 3:54 am
Location: Wine Country, Cal. USA

Re: Build 3.2 - Mouse Over Viewer Problem

Postby uckelman » April 23rd, 2012, 3:17 am

Thus spake DrNostromo:
> I'll look into it but I probably won't have time till Wednesday. I'll
> let you know.
>

Did you ever get around to trying this? If it's still a problem, we'd
like to fix it.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8798
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Build 3.2 - Mouse Over Viewer Problem

Postby DrNostromo » April 24th, 2012, 2:22 pm

I'm sorry. A buddy of mine and I have started selling CD's online and we've been totally immersed in that project lately. I'm off this Thursday and I will make a note to myself to test this.
User avatar
DrNostromo
 
Posts: 1061
Joined: December 21st, 2007, 3:54 am
Location: Wine Country, Cal. USA


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 5 guests