Create account / Log in

C&C: Ancients problem

Support for existing Vassal modules. Ask here if you need help with a specific module.

Moderators: Tim M, uckelman

C&C: Ancients problem

Postby derekrledr » July 21st, 2012, 6:11 pm

I played my first game of C&C: Ancients on Vassal this morning. I am running 3.2.0-beta1 (which I loaded to be able to run the latest version of B17), while my opponent was running 3.1.19. I created the game room and chose Battle of Akragas because neither of us had played the board game in quite some time. I chose to play Player 2 and my friend successfully synched as Player 1. He played the Syracusan side and his first turn behaved as expected. However, when I dragged and dropped my played card onto the board, my opponent could not see it. Throughout the game... I tried flipping it in my hand... flipping it on the mapboard... but nothing allowed him to see the card until either one of us dragged it onto the discard pile. Am I doing something wrong? Any suggestions?
Thanks, Derek
derekrledr
 
Posts: 22
Joined: March 4th, 2008, 6:45 am

Re: C&C: Ancients problem

Postby Brent Easton » July 21st, 2012, 11:01 pm

Yes,
Get your opponent to upgrade to 3.2.
Vassal should not have let your 3.1.19 opponents client sync to your 3.2 game. This will always cause many, varied and unpredictable problems for the 3.1 client.
Joel, Info.EXPIRY_VERSION stops 3.1 clients from editing 3.2 modules, it should stop them from syncing or even opening log files as well.
Brent.
User avatar
Brent Easton
 
Posts: 2757
Joined: December 21st, 2007, 3:06 am
Location: Berry, NSW, Australia

Re: C&C: Ancients problem

Postby derekrledr » July 22nd, 2012, 6:27 am

Hi Brent, Thanks for your prompt response. However, it cause me to realize that I was a bit vague in my first post... and that I am dealing with an unfortunate coincidence. My friend just downloaded the latest official versions on the Vassal website... which would be v 3.2 of Command & Colors: Ancients and v 3.1.19 of the Vassal platform. I was running v 3.2 of C&C:Ancients and 3.2.0-beta1 of the Vassal platform. We were both running the same version of C&C:Ancients... and I suspect that if there is a problem... I should go back to the official version of Vassal.
Derek
derekrledr
 
Posts: 22
Joined: March 4th, 2008, 6:45 am

Re: C&C: Ancients problem

Postby Brent Easton » July 22nd, 2012, 9:19 am

Derek,

You both need to be running the same version of Vassal, either both
running 3.1.19 or both running 3.2.0-beta1.

Brent.

On 22/07/2012 4:27 PM, derekrledr wrote:
> Hi Brent, Thanks for your prompt response. However, it cause me to
> realize that I was a bit vague in my first post... and that I am dealing
> with an unfortunate coincidence. My friend just downloaded the latest
> official versions on the Vassal website... which would be v 3.2 of
> Command & Colors: Ancients and v 3.1.19 of the Vassal platform. I was
> running v 3.2 of C&C:Ancients and 3.2.0-beta1 of the Vassal platform. We
> were both running the same version of C&C:Ancients... and I suspect that
> if there is a problem... I should go back to the official version of
> Vassal.
> Derek
>

--
____________________________________________________________
Brent Easton
Analyst/Programmer
University of Western Sydney
Email: b.easton@exemail.com.au
User avatar
Brent Easton
 
Posts: 2757
Joined: December 21st, 2007, 3:06 am
Location: Berry, NSW, Australia


Return to Module Support

Who is online

Users browsing this forum: No registered users and 2 guests