Create account / Log in

Small Grey Dot Dead Centre of Pieces

Issues with the Vassal engine.

Moderators: Tim M, uckelman

Small Grey Dot Dead Centre of Pieces

Postby yangtze » July 26th, 2012, 5:05 pm

Hi there

I'm noticing a small, grey dot which appears in the middle of all of the game pieces of all of the modules that I run (mainly hexgrid type wargames). This may just be an idiosyncrasy of Vassal that we all have to live with? Apologies if this issue is know or has been dealt with before - I did search 'small grey dot' but nothing came up.

I'm running a well-specced MacBook Pro 13" with the latest version of Vassal.

I hope someone out there understands what this is.

Best wishes.

Don
yangtze
 
Posts: 62
Joined: May 15th, 2008, 10:24 pm
Location: Nantwich, UK

Re: Small Grey Dot Dead Centre of Pieces

Postby Tim M » July 26th, 2012, 5:12 pm

could you give us a picture showing it as well as which module you are seeing
this in?



________________________________
From: yangtze
To: messages@vassalengine.org
Sent: Thu, July 26, 2012 12:05:55 PM
Subject: [messages] [Technical Support & Bugs] Small Grey Dot Dead Centre of
Pieces

Hi there

I'm noticing a small, grey dot which appears in the middle of all of the
game pieces of all of the modules that I run (mainly hexgrid type
wargames). This may just be an idiosyncrasy of Vassal that we all have
to live with? Apologies if this issue is know or has been dealt with
before - I did search 'small grey dot' but nothing came up.

I'm running a well-specced MacBook Pro 13" with the latest version of
Vassal.

I hope someone out there understands what this is.

Best wishes.

Don

_______________________________________________
Read this topic online here:
viewtopic.php?p=35384#p35384
Tim,
Vassal Uber Geek/Guru

Problems? post your OS, Physical Mem, version of Vassal and Java plus the Module in question.
No developer can help with out that info, thx!
User avatar
Tim M
 
Posts: 1777
Joined: December 8th, 2007, 12:22 pm
Location: Earth

Re: Small Grey Dot Dead Centre of Pieces

Postby yangtze » July 26th, 2012, 7:47 pm

Tim M wrote:could you give us a picture showing it as well as which module you are seeing
this in?

Pic attached. You can see the dot in all the pieces in this group. When the piece is first laid on the map and is still selected the dot is not there. Once the piece is deselected the dot appears and never goes.Image

________________________________
From: yangtze
To: messages@vassalengine.org
Sent: Thu, July 26, 2012 12:05:55 PM
Subject: [messages] [Technical Support & Bugs] Small Grey Dot Dead Centre of
Pieces

Hi there

I'm noticing a small, grey dot which appears in the middle of all of the
game pieces of all of the modules that I run (mainly hexgrid type
wargames). This may just be an idiosyncrasy of Vassal that we all have
to live with? Apologies if this issue is know or has been dealt with
before - I did search 'small grey dot' but nothing came up.

I'm running a well-specced MacBook Pro 13" with the latest version of
Vassal.

I hope someone out there understands what this is.

Best wishes.

Don

_______________________________________________
Read this topic online here:
viewtopic.php?p=35384#p35384
yangtze
 
Posts: 62
Joined: May 15th, 2008, 10:24 pm
Location: Nantwich, UK

Re: Small Grey Dot Dead Centre of Pieces

Postby yangtze » July 26th, 2012, 7:49 pm

Apologies, I'll have to give a mediafire link to the pic. It's a free download:

http://www.mediafire.com/?tie08iha7j1j0d8

I see this effect in every module, including Stalin's War.

Don



yangtze wrote:
Tim M wrote:could you give us a picture showing it as well as which module you are seeing
this in?

Pic attached. You can see the dot in all the pieces in this group. When the piece is first laid on the map and is still selected the dot is not there. Once the piece is deselected the dot appears and never goes.Image

________________________________
From: yangtze
To: messages@vassalengine.org
Sent: Thu, July 26, 2012 12:05:55 PM
Subject: [messages] [Technical Support & Bugs] Small Grey Dot Dead Centre of
Pieces

Hi there

I'm noticing a small, grey dot which appears in the middle of all of the
game pieces of all of the modules that I run (mainly hexgrid type
wargames). This may just be an idiosyncrasy of Vassal that we all have
to live with? Apologies if this issue is know or has been dealt with
before - I did search 'small grey dot' but nothing came up.

I'm running a well-specced MacBook Pro 13" with the latest version of
Vassal.

I hope someone out there understands what this is.

Best wishes.

Don

_______________________________________________
Read this topic online here:
viewtopic.php?p=35384#p35384
yangtze
 
Posts: 62
Joined: May 15th, 2008, 10:24 pm
Location: Nantwich, UK

Re: Small Grey Dot Dead Centre of Pieces

Postby uckelman » July 26th, 2012, 10:38 pm

Thus spake yangtze:
>
> http://www.mediafire.com/?tie08iha7j1j0d8
>

I checked Stalin's War. The dots are caused by the Movement Trail trait.
In particular, they disappear when "Trails start visible?" is unchecked,
but that appears also to have the effect of disabling movement trails
altogether when there's no key command defined.

It's unclear to me what the right thing to do here is.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8138
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Small Grey Dot Dead Centre of Pieces

Postby yangtze » July 27th, 2012, 12:28 am

Thanks for looking. Hopefully the issue will be solved in a future update?
yangtze
 
Posts: 62
Joined: May 15th, 2008, 10:24 pm
Location: Nantwich, UK

Re: Small Grey Dot Dead Centre of Pieces

Postby uckelman » July 27th, 2012, 8:03 am

Thus spake yangtze:
> Thanks for looking. Hopefully the issue will be solved in a future
> update?

What's not clear to me is whether this is our bug or a module bug.
Anyone else care to comment?

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8138
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Small Grey Dot Dead Centre of Pieces

Postby barbanera » July 27th, 2012, 11:45 am

uckelman wrote:Thus spake yangtze:
>
> http://www.mediafire.com/?tie08iha7j1j0d8
>

I checked Stalin's War. The dots are caused by the Movement Trail trait.
In particular, they disappear when "Trails start visible?" is unchecked,
but that appears also to have the effect of disabling movement trails
altogether when there's no key command defined.

It's unclear to me what the right thing to do here is.

--
J.


Never used the Movement Trail myself, but maybe leaving "Trails start visible" unchecked but fixing the engine so that trails do show up even with no key command defined is the ideal solution?
barbanera
 
Posts: 377
Joined: January 12th, 2012, 2:27 pm

Re: Small Grey Dot Dead Centre of Pieces

Postby uckelman » July 29th, 2012, 2:25 pm

Thus spake barbanera:
>
> "uckelman" wrote:
> > Thus spake yangtze:
> > >
> > > http://www.mediafire.com/?tie08iha7j1j0d8[1]
> > >
> >
> > I checked Stalin's War. The dots are caused by the Movement Trail
> > trait.
> > In particular, they disappear when "Trails start visible?" is
> > unchecked,
> > but that appears also to have the effect of disabling movement trails
> > altogether when there's no key command defined.
> >
> > It's unclear to me what the right thing to do here is.
> >
> > --
> > J.
>
>
> Never used the Movement Trail myself, but maybe leaving "Trails start
> visible" unchecked but fixing the engine so that trails do show up even
> with no key command defined is the ideal solution?
>
> [1] http://www.mediafire.com/?tie08iha7j1j0d8
>

This turned out to be a bug in the way line segments were drawn. There
was no check of whether the final point in the points list is the same
as the current location of the piece, which resulted in a zero-length
(but not zero-width) line segment being drawn at the location of each
unmoved piece.

This bug has existed as long as the Movement Trail trait has. It's
amazing to me that no one told us about it before.

Try 3.1.20-svn8234:

http://www.vassalengine.org/~uckelman/builds/

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8138
Joined: December 10th, 2007, 9:48 am
Location: Durham, England


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 2 guests