Create account / Log in

Release candidate for 3.2.0-beta2

Discussion area for the development team.

Moderators: uckelman, Tim M

Release candidate for 3.2.0-beta2

Postby uckelman » September 13th, 2012, 10:20 pm

I've just uploaded 3.2.0-svn8342 to the usual place:

http://www.vassalengine.org/~uckelman/builds/

If no one objects, I'd like to release this as 3.2.0-beta2 over the weekend.
User avatar
uckelman
Site Admin
 
Posts: 8798
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Release candidate for 3.2.0-beta2

Postby uckelman » September 15th, 2012, 11:45 am

No one complained, so I've released 3.2.0-beta2.
User avatar
uckelman
Site Admin
 
Posts: 8798
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Release candidate for 3.2.0-beta2

Postby Flaney » September 16th, 2012, 7:04 am

I am finding when opening my module I get errors that were not appearing before Beta2:

Bad Data in Module: [Layer-Sector:] - Numeric field contains a non-number followProperty[TileStatus]=

where TileStatus is a numeric [DP] used in [Layer] Follow Expression: TileStatus.

This [DP] can be placed before or after the [Layer] without changing the error.


Is there any explanation for the Layer change and a suggestion to repair it (I have this error for several components in my module)?

Thanks

Flaney
Flaney
 
Posts: 106
Joined: March 18th, 2011, 9:11 am

Re: Release candidate for 3.2.0-beta2

Postby Brent Easton » September 16th, 2012, 8:39 am

Opening the module in edit or play mode?
Do the errors occur when you first open the module, or when you start a new game?
Could you please include the top 20 lines or so of the errorlog?
What module is this so I can try for myself?
B.
User avatar
Brent Easton
 
Posts: 3090
Joined: December 21st, 2007, 3:06 am
Location: Berry, NSW, Australia

Re: Release candidate for 3.2.0-beta2

Postby mroyer » September 16th, 2012, 11:46 am

uckelman wrote:No one complained, so I've released 3.2.0-beta2.


Sorry for the late reply... but when I click or double-click on VASSAL-3.2.0-svn8342-windows.exe I get an endless hour-glass and the install never progresses. (I usually try to install the new builds straight away but I was unavailable for a bit - sorry for the delay.)

-Mark R.
mroyer
 
Posts: 166
Joined: March 4th, 2011, 5:06 pm
Location: Massachusetts

Re: Release candidate for 3.2.0-beta2

Postby uckelman » September 16th, 2012, 12:05 pm

Thus spake mroyer:
>
> "uckelman" wrote:
> > No one complained, so I've released 3.2.0-beta2.
>
>
> Sorry for the late reply... but when I click or double-click on
> VASSAL-3.2.0-svn8342-windows.exe I get an endless hour-glass and the
> install never progresses. (I usually try to install the new builds
> straight away but I was unavailable for a bit - sorry for the delay.)

Are you trying to install while you have an instance of VASSAL already
running?
--
J.
User avatar
uckelman
Site Admin
 
Posts: 8798
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Release candidate for 3.2.0-beta2

Postby mroyer » September 16th, 2012, 12:25 pm

uckelman wrote:Are you trying to install while you have an instance of VASSAL already
running?
--
J.


Nope... no instances running - I just tried again to make sure.
Ultimately, I'll need to terminate explorer.exe and restart it go get out of the problem.


Addendum: Actually, this time I stuck it out for, perhaps, 5 minutes or so and the install finally started. I'll let you know how it goes.
mroyer
 
Posts: 166
Joined: March 4th, 2011, 5:06 pm
Location: Massachusetts

Re: Release candidate for 3.2.0-beta2

Postby mroyer » September 16th, 2012, 12:45 pm

mroyer wrote:Addendum: Actually, this time I stuck it out for, perhaps, 5 minutes or so and the install finally started. I'll let you know how it goes.


So, after a while it finally finished and appears to have installed correctly.
On looking closer, I noticed that a green-bar was slowly traversing the top of my explorer window each time clicked on the VASSAL install .exe. (see attachment) I'm not sure of the significance of the green bar, but it doesn't seem like the install gets rolling until the bar has reached the right-hand side of the explorer window. The green bar does not appear at all on earlier build install .exe's.

-Mark R.
Attachments
Untitled.png
Untitled.png (78.95 KiB) Viewed 5176 times
mroyer
 
Posts: 166
Joined: March 4th, 2011, 5:06 pm
Location: Massachusetts

Re: Release candidate for 3.2.0-beta2

Postby uckelman » September 16th, 2012, 1:44 pm

Thus spake mroyer:
>
> "mroyer" wrote:
> >
> > Addendum: Actually, this time I stuck it out for, perhaps, 5 minutes
> > or so and the install finally started. I'll let you know how it goes.
>
>
> So, after a while it finally finished and appears to have installed
> correctly.
> On looking closer, I noticed that a green-bar was slowly traversing the
> top of my explorer window each time clicked on the VASSAL install .exe.
> (see attachment) I'm not sure of the significance of the green bar, but
> it doesn't seem like the install gets rolling until the bar has reached
> the right-hand side of the explorer window. The green bar does not
> appear at all on earlier build install .exe's.

That's weird. I have no idea why that would be.

Does this happen with 3.2.0-beta2?

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8798
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Release candidate for 3.2.0-beta2

Postby Flaney » September 16th, 2012, 9:00 pm

Brent Easton wrote:Opening the module in edit or play mode?
Do the errors occur when you first open the module, or when you start a new game?
Could you please include the top 20 lines or so of the errorlog?
What module is this so I can try for myself?
B.


The errors occur when I opened to edit before selecting File | New Game.
I do get a similar error for a pieceUnit with layers when I move it the main map. These don't occur in build 8330.
This module is is one I am building and weighs in at 11MB.

Errorlog
2012-09-16 13:45:50,062 [0-SwingWorker-pool-21168641-thread-2] INFO VASSAL.launch.AbstractLaunchAction - Loading module file C:\PROJECTS\Vassal\module\CGS_Babylon5+.vmod
2012-09-16 13:45:50,218 [0-SwingWorker-pool-21168641-thread-2] INFO VASSAL.launch.TilingHandler - No images to tile.
2012-09-16 13:45:50,218 [0-SwingWorker-pool-21168641-thread-2] INFO VASSAL.launch.AbstractLaunchAction - Loading module CGS-Babylon5
2012-09-16 13:45:50,218 [0-SwingWorker-pool-21168641-thread-2] INFO VASSAL.tools.io.ProcessLauncher - launching C:\Program Files\Java\jre7\bin\java -Xms256M -Xmx512M -DVASSAL.id=3 -DVASSAL.port=1324 -Duser.home=C:\Documents and Settings\Flane -cp lib\Vengine.jar VASSAL.launch.Editor --edit -- C:\PROJECTS\Vassal\module\CGS_Babylon5+.vmod
2012-09-16 13:45:51,078 [3-main] INFO VASSAL.launch.StartUp - Starting
2012-09-16 13:45:51,078 [3-main] INFO VASSAL.launch.StartUp - OS Windows XP
2012-09-16 13:45:51,078 [3-main] INFO VASSAL.launch.StartUp - Java version 1.7.0_07
2012-09-16 13:45:51,078 [3-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.0-svn8342
2012-09-16 13:45:51,078 [3-main] INFO VASSAL.launch.Launcher - Editor
2012-09-16 13:45:52,750 [3-AWT-EventQueue-0] INFO VASSAL.script.ExpressionInterpreter - Attempting to load /VASSAL/script/init_expression.bsh URI generated=jar:file:/C:/Program%20Files/VASSAL-3.2.0-svn8342/lib/Vengine.jar!/VASSAL/script/init_expression.bsh
2012-09-16 13:45:52,781 [3-AWT-EventQueue-0] WARN VASSAL.tools.ErrorDialog - [Layer - Sector:] - Numeric field contains a non-number: followProperty[TileStatus]=
2012-09-16 13:45:52,796 [3-AWT-EventQueue-0] ERROR VASSAL.tools.ErrorDialog -
java.lang.NumberFormatException: For input string: ""
at java.lang.NumberFormatException.forInputString(Unknown Source) ~[na:1.7.0_07]
at java.lang.Integer.parseInt(Unknown Source) ~[na:1.7.0_07]
at java.lang.Integer.parseInt(Unknown Source) ~[na:1.7.0_07]
at VASSAL.counters.Embellishment.checkPropertyLevel(Embellishment.java:503) [Vengine.jar:na]
at VASSAL.counters.Embellishment.getName(Embellishment.java:352) [Vengine.jar:na]
at VASSAL.counters.Embellishment.getName(Embellishment.java:348) [Vengine.jar:na]
at VASSAL.counters.DynamicProperty.getName(DynamicProperty.java:130) [Vengine.jar:na]
at VASSAL.counters.Delete.getName(Delete.java:134) [Vengine.jar:na]
at VASSAL.counters.NonRectangular.getName(NonRectangular.java:103) [Vengine.jar:na]
at VASSAL.counters.Immobilized.getName(Immobilized.java:167) [Vengine.jar:na]
at VASSAL.counters.FreeRotator.getName(FreeRotator.java:137) [Vengine.jar:na]
at VASSAL.counters.RestrictCommands.getName(RestrictCommands.java:81) [Vengine.jar:na]
at VASSAL.counters.Labeler.setLabel(Labeler.java:408) [Vengine.jar:na]
at VASSAL.counters.Labeler.mySetState(Labeler.java:213) [Vengine.jar:na]
at VASSAL.counters.Decorator.setState(Decorator.java:160) [Vengine.jar:na]
at VASSAL.counters.Decorator.setState(Decorator.java:162) [Vengine.jar:na]
at VASSAL.counters.Decorator.setState(Decorator.java:162) [Vengine.jar:na]
at VASSAL.counters.Decorator.setState(Decorator.java:162) [Vengine.jar:na]
at VASSAL.build.module.PrototypeDefinition.getPiece(PrototypeDefinition.java:147) [Vengine.jar:na]
at VASSAL.build.module.PrototypeDefinition.getPiece(PrototypeDefinition.java:123) [Vengine.jar:na]
at VASSAL.build.module.PrototypeDefinition.getI18nData(PrototypeDefinition.java:295) [Vengine.jar:na]
at VASSAL.build.AbstractConfigurable.add(AbstractConfigurable.java:141) [Vengine.jar:na]
at VASSAL.build.module.PrototypesContainer.add(PrototypesContainer.java:83) [Vengine.jar:na]
at VASSAL.build.Builder.build(Builder.java:82) [Vengine.jar:na]
at VASSAL.build.AbstractBuildable.build(AbstractBuildable.java:69) [Vengine.jar:na]
at VASSAL.build.Builder.create(Builder.java:117) [Vengine.jar:na]
at VASSAL.build.Builder.build(Builder.java:79) [Vengine.jar:na]
at VASSAL.build.AbstractBuildable.build(AbstractBuildable.java:69) [Vengine.jar:na]
at VASSAL.launch.BasicModule.build(BasicModule.java:148) [Vengine.jar:na]
at VASSAL.launch.BasicModule.build(BasicModule.java:111) [Vengine.jar:na]
at VASSAL.build.GameModule.init(GameModule.java:853) [Vengine.jar:na]
at VASSAL.launch.EditModuleAction.loadModule(EditModuleAction.java:48) [Vengine.jar:na]
at VASSAL.launch.Editor.launch(Editor.java:74) [Vengine.jar:na]
at VASSAL.launch.Launcher$1.run(Launcher.java:149) [Vengine.jar:na]
at java.awt.event.InvocationEvent.dispatch(Unknown Source) [na:1.7.0_07]
at java.awt.EventQueue.dispatchEventImpl(Unknown Source) [na:1.7.0_07]
at java.awt.EventQueue.access$200(Unknown Source) [na:1.7.0_07]
at java.awt.EventQueue$3.run(Unknown Source) [na:1.7.0_07]
at java.awt.EventQueue$3.run(Unknown Source) [na:1.7.0_07]
at java.security.AccessController.doPrivileged(Native Method) [na:1.7.0_07]
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source) [na:1.7.0_07]
at java.awt.EventQueue.dispatchEvent(Unknown Source) [na:1.7.0_07]
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source) [na:1.7.0_07]
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source) [na:1.7.0_07]
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source) [na:1.7.0_07]
at java.awt.EventDispatchThread.pumpEvents(Unknown Source) [na:1.7.0_07]
at java.awt.EventDispatchThread.pumpEvents(Unknown Source) [na:1.7.0_07]
at java.awt.EventDispatchThread.run(Unknown Source) [na:1.7.0_07]
2012-09-16 13:45:53,093 [3-AWT-EventQueue-0] WARN VASSAL.tools.ErrorDialog - Centauri [Layer - Reticle-Attack] - Numeric field contains a non-number: followProperty[G_AttackTotal]=
2012-09-16 13:45:53,109 [3-AWT-EventQueue-0] ERROR VASSAL.tools.ErrorDialog -
java.lang.NumberFormatException: For input string: ""
Flaney
 
Posts: 106
Joined: March 18th, 2011, 9:11 am


Return to Developers

Who is online

Users browsing this forum: No registered users and 0 guests