Create account / Log in

Cards not drawing when dragged since Java update

Issues with the Vassal engine.

Moderators: uckelman, Tim M

Cards not drawing when dragged since Java update

Postby rodwell » September 24th, 2013, 10:34 am

[*] Windows 7 Professional 64bit
[*] Intel i7 920
[*] 6GB RAM
[*] Nvidia GeForce GTX 285
[*] Vassal 3.2.8

Today I updated Java to 'Version 7 Update 40 (build 1.7.0_40-b43)'. I'm afraid I do not know the previous version I had before the update.

Since the update, when I drag a card it no longer draws until I release it. All other aspects of the drag work correctly: the pointer turns into the 'hand' icon for the duration and the card is dropped in the correct position but it is simply not being drawn whilst dragging.

An example of a public module where this happens in 'Legendary: A Marvel Deck Building Game' but I am also seeing the effect in my own modules.
rodwell
 
Posts: 8
Joined: February 17th, 2011, 2:54 pm

Re: Cards not drawing when dragged since Java update

Postby rodwell » September 25th, 2013, 11:54 am

In case it's useful, I found I still have an older version of Java on this computer: 1.6.0_45 and if I force Vassal to use it then the problem goes away.
rodwell
 
Posts: 8
Joined: February 17th, 2011, 2:54 pm

Re: Cards not drawing when dragged since Java update

Postby Brigz » September 27th, 2013, 11:11 pm

I have also had this problem. When dragging counters from one location to the other using the mouse, the counter disappears and does not reappear until the mouse button is released. I have written to this forum asking how to remedy this but no one was able to help. I also have reinstalled Vassal several times, up to the current version.
Brigz
 
Posts: 73
Joined: December 21st, 2007, 3:08 am
Location: Sacramento

Re: Cards not drawing when dragged since Java update

Postby uckelman » September 28th, 2013, 7:30 am

Thus spake Brigz:
> I have also had this problem. When dragging counters from one location
> to the other using the mouse, the counter disappears and does not
> reappear until the mouse button is released. I have written to this
> forum asking how to remedy this but no one was able to help. I also have
> reinstalled Vassal several times, up to the current version.

The only problem that reinstalling VASSAL will ever solve is if some
of VASSAL's files are corrupted. If that happens, you probably won't
be able to start VASSAL. Therefore: If you can start VASSAL,
reinstalling is unlikely to solve your problem. I wish we could convey
to everyone that reinstalling VASSAL is a waste of time except in very
specific circumstances.

Your particular problem is caused by a change in behavior from Java 6
to Java 7. I haven't had time yet to look into whether it's a
documented change in behavior or if VASSAL was relying on undocumented
behavior in Java 6---in which case the problem is ours---or whether we
are relying on unchanged, documented behavior, in which case it is a
bug in Java 7.

For the time being, if you want this to work properly, use Java 6.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 9014
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Cards not drawing when dragged since Java update

Postby Brigz » September 28th, 2013, 3:00 pm

Thanks for the info. I'll try to run Java 6 and see what happens.

Glad to hear that reinstalling doesn't solve anything. I did not know that.

Dave
Brigz
 
Posts: 73
Joined: December 21st, 2007, 3:08 am
Location: Sacramento

Re: Cards not drawing when dragged since Java update

Postby uckelman » September 28th, 2013, 7:52 pm

I can't reproduce this problem with Java 7 (OpenJDK 1.7.0_60) on Linux. That makes it likely to be a bug in Java 7 on Windows.
User avatar
uckelman
Site Admin
 
Posts: 9014
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Cards not drawing when dragged since Java update

Postby uckelman » September 28th, 2013, 8:08 pm

If you want this problem solved, if would be helpful for us to know if there is a last working version of Java 7. You can find old versions of Java 7 here.

The ones you want to try are labeled "Java SE Runtime Environment". Before trying any of these, you should first uninstall the Java 7 you have now (which will be newer), and after each Java install, you must reboot your computer before starting VASSAL.
User avatar
uckelman
Site Admin
 
Posts: 9014
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Cards not drawing when dragged since Java update

Postby Brent Easton » September 30th, 2013, 1:27 am

I have the problem also, I will try and look into it.
User avatar
Brent Easton
 
Posts: 3229
Joined: December 21st, 2007, 3:06 am
Location: Berry, NSW, Australia

Re: Cards not drawing when dragged since Java update

Postby Brent Easton » September 30th, 2013, 3:04 am

Bug 10295 - No Drag Cursors when dragging units on Windows 7 using Java 7
User avatar
Brent Easton
 
Posts: 3229
Joined: December 21st, 2007, 3:06 am
Location: Berry, NSW, Australia

Re: Cards not drawing when dragged since Java update

Postby Brigz » September 30th, 2013, 3:33 pm

Thanks for looking into this guys. I made some posts here about this last April but was not able to find a solution.
viewtopic.php?f=3&t=5535
Brigz
 
Posts: 73
Joined: December 21st, 2007, 3:08 am
Location: Sacramento


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 4 guests