Create account / Log in

Vassal-3.2.10 wont start

Issues with the Vassal engine.

Moderators: Tim M, uckelman

Re: Vassal-3.2.10 wont start

Postby uckelman » February 24th, 2014, 10:51 pm

Thus spake Rindis:
>
> "uckelman" wrote:
> > Rindis, if VASSAL now won't start for you on subsequent attempts,
> > please post the errorLog you're getting from the first attempt.
>
> Okay, error log after first (successful) launch on Win 8:
> 2014-02-24 08:41:30,807 [0-main] INFO VASSAL.launch.StartUp - Starting
> 2014-02-24 08:41:30,807 [0-main] INFO VASSAL.launch.StartUp - OS
> Windows 8 6.2
> 2014-02-24 08:41:30,807 [0-main] INFO VASSAL.launch.StartUp - Java
> version 1.6.0_45
> 2014-02-24 08:41:30,807 [0-main] INFO VASSAL.launch.StartUp - VASSAL
> version 3.2.12-svn9019
> 2014-02-24 08:41:30,994 [0-AWT-EventQueue-0] INFO
> VASSAL.launch.ModuleManager - Manager
> 2014-02-24 08:41:46,813 [0-AWT-EventQueue-0] INFO
> VASSAL.launch.ModuleManagerWindow - Exiting
>
> And it doesn't start on the second go, and the Error Log is not updated.
>
> I'll try to remember to test svn9016 on my Win7 desktop tonight.

Please also try to determine the latest version which does not have
the startup problem for you.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8140
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Vassal-3.2.10 wont start

Postby Rindis » February 25th, 2014, 3:16 am

uckelman wrote:Thus spake Rindis:
>
> Standard install goes fine, and the menu shortcut now points at the
> standard (64-bit) directory, and will launch Vassal fine. However, the
> Java problem causing it to not be able to launch twice in a row (as
> above) persists.

Now it looks like you're having the same problem as BsKene and
sithstalker.

>
> I tend to suspect that something odd (and likely inexplicable) just
> happened when I installed 3.2.11 on my main machine. But the fact that
> the installer can't see the previous version is interesting.

Check in the registry under HKLM\Software\vassalengine.org\VASSAL.
What do you see there?

Does the 3.2.12-svn9016 installer see 3.2.11?

--
J.

Registry: I see a subfolder marked "VASSAL (3.1.20)" with an InstallLocation key (or whatever it would be called).

The svn9016 installer only sees 3.1.20. It does not see 3.2.11, nor does it see 3.2.12-svn9019 (which is still installed).
User avatar
Rindis
 
Posts: 196
Joined: December 22nd, 2007, 12:49 am

Re: Vassal-3.2.10 wont start

Postby Rindis » February 25th, 2014, 3:28 am

uckelman wrote:Thus spake Rindis:
>
> "uckelman" wrote:
> > Rindis, if VASSAL now won't start for you on subsequent attempts,
> > please post the errorLog you're getting from the first attempt.
>
> Okay, error log after first (successful) launch on Win 8:
> 2014-02-24 08:41:30,807 [0-main] INFO VASSAL.launch.StartUp - Starting
> 2014-02-24 08:41:30,807 [0-main] INFO VASSAL.launch.StartUp - OS
> Windows 8 6.2
> 2014-02-24 08:41:30,807 [0-main] INFO VASSAL.launch.StartUp - Java
> version 1.6.0_45
> 2014-02-24 08:41:30,807 [0-main] INFO VASSAL.launch.StartUp - VASSAL
> version 3.2.12-svn9019
> 2014-02-24 08:41:30,994 [0-AWT-EventQueue-0] INFO
> VASSAL.launch.ModuleManager - Manager
> 2014-02-24 08:41:46,813 [0-AWT-EventQueue-0] INFO
> VASSAL.launch.ModuleManagerWindow - Exiting
>
> And it doesn't start on the second go, and the Error Log is not updated.
>
> I'll try to remember to test svn9016 on my Win7 desktop tonight.

Please also try to determine the latest version which does not have
the startup problem for you.

--
J.

I... can't seem to find one that doesn't have the problem. I've gone all the way back to 3.1.17 (earliest version I had to hand), and they all showed the same behavior on my Win 8 machine.

If there's any particular version you want me to try, just tell me.
User avatar
Rindis
 
Posts: 196
Joined: December 22nd, 2007, 12:49 am

Re: Vassal-3.2.10 wont start

Postby uckelman » February 25th, 2014, 8:40 am

Thus spake Rindis:
>
> Registry: I see a subfolder marked "VASSAL (3.1.20)" with an
> InstallLocation key (or whatever it would be called).
>
> The svn9016 installer only sees 3.1.20. It does not see 3.2.11, nor does
> it see 3.2.12-svn9019 (which is still installed).

What does the 3.2.12-svn9019 installer see?

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8140
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Vassal-3.2.10 wont start

Postby uckelman » February 25th, 2014, 8:43 am

Thus spake Rindis:
>
> I... can't seem to find one that _doesn't_ have the problem. I've gone
> all the way back to 3.1.17 (earliest version I had to hand), and they
> all showed the same behavior on my Win 8 machine.
>

This is exactly what I expected would happen. I think the problem
is with your install of Java, not with VASSAL. Try uninstalling and
reinstalling Java.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8140
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Vassal-3.2.10 wont start

Postby Rindis » February 25th, 2014, 4:44 pm

uckelman wrote:Thus spake Rindis:
>
> I... can't seem to find one that _doesn't_ have the problem. I've gone
> all the way back to 3.1.17 (earliest version I had to hand), and they
> all showed the same behavior on my Win 8 machine.
>

This is exactly what I expected would happen. I think the problem
is with your install of Java, not with VASSAL. Try uninstalling and
reinstalling Java.

--
J.

Hmm... two versions of Java present: 6 Update 27 and 6 Update 45 (64-bit)....

Uninstalled both, went to java.com, and it installed 6 Update 51. Reinstalled Vassal 3.2.11, and it seems to work now.

Now, I hadn't fiddled with Java on my machine. (I think the second copy is from Vassal 3.1.20 installing.) So, I would *think* that it was still the original configuration from Microsoft when they put together the Surface Pro 2....
User avatar
Rindis
 
Posts: 196
Joined: December 22nd, 2007, 12:49 am

Re: Vassal-3.2.10 wont start

Postby uckelman » February 25th, 2014, 6:18 pm

Thus spake Rindis:
>
> "uckelman" wrote:
> > Thus spake Rindis:
> > >
> > > I... can't seem to find one that _doesn't_ have the problem. I've
> > gone
> > > all the way back to 3.1.17 (earliest version I had to hand), and
> > they
> > > all showed the same behavior on my Win 8 machine.
> > >
> >
> > This is exactly what I expected would happen. I think the problem
> > is with your install of Java, not with VASSAL. Try uninstalling and
> > reinstalling Java.
> >
> > --
> > J.
>
> Hmm... two versions of Java present: 6 Update 27 and 6 Update 45
> (64-bit)....

Oh, yes. Having more than one version of Java installed tends to
cause neither to work properly, in my experience. I should have asked
about that.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8140
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Vassal-3.2.10 wont start

Postby uckelman » February 26th, 2014, 7:28 pm

Rindis, I believe I know why your file associations disappeared: The uninstaller was unconditionally removing VASSAL file associations if they existed---which is incorrect if those file associations were put there by a different version of VASSAL. This causes a problem only when you run the uninstaller manually. When the uninstaller is launched from a later version of the installer, new file associations are established by the (new) installer after the (old) uninstaller removes them, which is why most people would never see the problem.

I've fixed this in 3.2.12-svn9021: http://vassalengine.sourceforge.net/builds/
User avatar
uckelman
Site Admin
 
Posts: 8140
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Vassal-3.2.10 wont start

Postby uckelman » February 26th, 2014, 7:37 pm

I won't do anything further on this problem until I hear back that someone having it has only one version of Java installed.
User avatar
uckelman
Site Admin
 
Posts: 8140
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Vassal-3.2.10 wont start

Postby BSkene » March 24th, 2014, 5:21 am

Sorry I didn't respond for so long after you've been so helpful. but I was distracted by work and other issues. I uninstalled and reisntalled java (there were two versions), then installed the new Vassal version posted just above (3.2.12-svn9021) and was just now able to repeatedly open and close vassal, so it seems as if you've solved it, thanks.

Incidentally, what game does your icon come from?
BSkene
 
Posts: 11
Joined: February 11th, 2014, 12:15 am

Re: Vassal-3.2.10 wont start

Postby uckelman » March 24th, 2014, 9:35 pm

Thus spake BSkene:
> Sorry I didn't respond for so long after you've been so helpful. but I
> was distracted by work and other issues. I uninstalled and reisntalled
> java (there were two versions), then installed the new Vassal version
> posted just above (3.2.12-svn9021) and was just now able to repeatedly
> open and close vassal, so it seems as if you've solved it, thanks.

I'm glad it workd for you now.

> Incidentally, what game does your icon come from?

That icon is from the Cyberboard gamebox for AH's The Longest Day.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8140
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Vassal-3.2.10 wont start

Postby sithstalker » March 30th, 2014, 10:27 pm

The 3.2.12-svn9021 version didn't solve this for me, so I just stayed with 3.2.11; however, I need to use Task Manager to end task on Java, and then can restart Vassal, and it works fine after the restart. Thanks for your effort!
sithstalker
 
Posts: 14
Joined: April 16th, 2013, 8:56 pm

Re: Vassal-3.2.10 wont start

Postby uckelman » March 31st, 2014, 9:14 am

Thus spake sithstalker:
> The 3.2.12-svn9021 version didn't solve this for me, so I just stayed
> with 3.2.11; however, I need to use Task Manager to end task on Java,
> and then can restart Vassal, and it works fine after the restart. Thanks
> for your effort!
>

Did you check whether you have more than one version of Java installed?

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8140
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Vassal-3.2.10 wont start

Postby sithstalker » April 4th, 2014, 11:51 pm

Yes, I checked and only have one version, in a folder "jre6" under "program files".
sithstalker
 
Posts: 14
Joined: April 16th, 2013, 8:56 pm

Re: Vassal-3.2.10 wont start

Postby uckelman » April 6th, 2014, 12:56 pm

Thus spake sithstalker:
> Yes, I checked and only have one version, in a folder "jre6" under
> "program files".
>

That's not the way to check. You need to look in "Add/Remove Programs".

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8140
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

PreviousNext

Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 0 guests