Create account / Log in

bug report?

Issues with the Vassal engine.

Moderators: Tim M, uckelman

bug report?

Postby hutonahill » November 21st, 2019, 1:30 am

tried to boot up the game for the first time. it game be the "oh no! its a bug" screen. tried to submit a bug report, but it said it couldn't. so here I am.

I am running OSX 10.14.6 with 32 GB of RAM, an 3.2 GHz Intel Core i5, and 32-bit Java.

I attached the error log.

if you have any questions, please reply to this.
Attachments
errorLog copy.zip
(1.86 KiB) Downloaded 62 times
hutonahill
 
Posts: 3
Joined: December 7th, 2018, 7:07 pm

Re: bug report?

Postby uckelman » November 26th, 2019, 8:57 pm

Thus spake hutonahill:
> tried to boot up the game for the first time. it game be the "oh no! its
> a bug" screen. tried to submit a bug report, but it said it couldn't. so
> here I am.
>
> I am running OSX 10.14.6 with 32 GB of RAM, an 3.2 GHz Intel Core i5,
> and 32-bit Java.
>
> I attached the error log.

You're using Java 9. VASSAL 3.2 won't work with anything newer than Java 8.

VASSAL 3.3 will work with Java 9 and later, but isn't ready for release
yet. (There's a blocker regarding HiDPI scaling which we have yet to
resolve, and it looks like I won't have time to return to working on it
before the second week of December.)

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8147
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: bug report?

Postby hutonahill » November 29th, 2019, 3:32 am

oh, sadness. thanks
hutonahill
 
Posts: 3
Joined: December 7th, 2018, 7:07 pm

Re: bug report?

Postby uckelman » November 29th, 2019, 8:51 pm

Thus spake hutonahill:
> oh, sadness. thanks

This shouldn't be a blocker---you could install Java 8 and use that
in the meantime.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8147
Joined: December 10th, 2007, 9:48 am
Location: Durham, England


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 0 guests