Create account / Log in

Ubuntu Bug Report

Issues with the Vassal engine.

Moderators: Tim M, uckelman

Ubuntu Bug Report

Postby Hydrohead » December 8th, 2019, 1:32 am

I just got vassal installed on a new Ubuntu computer and when I tried to load my first module, I got a bug warning and it was not able to be submitted through the apps bug reporter. The bug reporter sent me here.

The error log is attached.
And the module I was attempting to load is here: http://www.vassalengine.org/mediawiki/i ... G_4.5.vmod

I have notifications turned on. If there is anything else I can provide or options I should try, just let me know.

OS: Ubuntu 18.04.3 LTS
Attachments
errorLog.txt
(51.48 KiB) Downloaded 104 times
Hydrohead
 
Posts: 3
Joined: September 1st, 2019, 4:12 am

Re: Ubuntu Bug Report

Postby uckelman » December 8th, 2019, 11:18 pm

Thus spake Hydrohead:
> I just got vassal installed on a new Ubuntu computer and when I tried to
> load my first module, I got a bug warning and it was not able to be
> submitted through the apps bug reporter. The bug reporter sent me here.

The problem is that you're using Java 11 with VASSAL 3.2.17. The newest
Java which will work with 3.2.17 is Java 8.

We're working on 3.3.0 presently which will work with Java 9 and later;
in the meantime, use Java 8 with 3.2.17.

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8382
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: Ubuntu Bug Report

Postby Hydrohead » December 9th, 2019, 11:45 pm

Thanks! That fixed it.
Hydrohead
 
Posts: 3
Joined: September 1st, 2019, 4:12 am


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 3 guests