Create account / Log in

modules will not open

Issues with the Vassal engine.

Moderators: uckelman, Tim M

modules will not open

Postby rromer10 » March 24th, 2020, 3:04 pm

Model Macbook pro (retina15inchmid 2014)
op system MacOs Mojave version 10.14.6
cpu:
Memory 16GB
video:
Vassal 3.2.17
Java Java for Osx-x64.dmg
vassal module name GMT games Saratoga, Also 3 days of Gettysburg

I have Adobe Flash, I downloaded Oracle Vassal and also Apple Java 6 for legacy games after i could not get module to open.
I updated vassal to most recent version. When I went to open modules from downloads, nothing would happen. I tried right clicking and open with vassal i went back to page to play module go to vassal engine.org. I hope you can help as I am not very computer savvy. Thanks, Rich
rromer10
 
Posts: 2
Joined: February 3rd, 2015, 3:39 am

Re: modules will not open

Postby COLBOT » March 29th, 2020, 2:43 am

I'm having the same problem with my Mac with similar specs!
The Star Wars Xwing Miniatures module won't open.
COLBOT
 
Posts: 1
Joined: March 29th, 2020, 2:42 am

Re: modules will not open

Postby uckelman » March 29th, 2020, 3:55 pm

In order to help you, we need more information.

* What version of Java are you actually using? (You can check that by typing 'java -version' in a terminal.)
* What is in VASSAL's errorLog after you try running it? (On a Mac, you should find that in ~/Library/Application Support/VASSAL.)
User avatar
uckelman
Site Admin
 
Posts: 8555
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: modules will not open

Postby MaxSterling » April 1st, 2020, 3:03 pm

I am having a similar issue on my Macbook.
(File not found 'manifest.json' not found in /) Is there a separate place to download the manifest.json?
Anyone have an idea on how to fix, looking to get into the Janktank Open.

Error: can't connect online to verify the module's integrity with xwing-data2 - will attempt to use local files instead.
--- File not found 'manifest.json' not found in /Users/eadamiano/Desktop/Vassal/xwd2.zip
XWS2Upgrades line 343 - couldn't load the manifest for upgrades
XWS2Upgrades line 343 - couldn't load the manifest for conditions
XWS2Upgrades line 323 - couldn't load the manifest for conditions
- Star Wars X-Wing Miniatures Game version 8.8.1

The following is my error log:
2020-04-01 08:46:32,425 [0-main] INFO VASSAL.launch.StartUp - Starting
2020-04-01 08:46:32,432 [0-main] INFO VASSAL.launch.StartUp - OS Mac OS X 10.13.6
2020-04-01 08:46:32,432 [0-main] INFO VASSAL.launch.StartUp - Java version 1.6.0_65
2020-04-01 08:46:32,432 [0-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.17
2020-04-01 08:46:33,047 [0-AWT-EventQueue-0] INFO VASSAL.launch.ModuleManager - Manager
2020-04-01 08:46:46,294 [0-SwingWorker-pool-1619027613-thread-1] INFO VASSAL.launch.AbstractLaunchAction - Loading module file /Users/eadamiano/Desktop/Vassal/Star_Wars_X-Wing_Miniatures_Game-8.8.1-1.vmod
2020-04-01 08:46:47,656 [0-SwingWorker-pool-1619027613-thread-1] INFO VASSAL.launch.TilingHandler - No images to tile.
2020-04-01 08:46:47,657 [0-SwingWorker-pool-1619027613-thread-1] INFO VASSAL.launch.AbstractLaunchAction - Loading module Star Wars X-Wing Miniatures Game
2020-04-01 08:46:47,660 [0-SwingWorker-pool-1619027613-thread-1] INFO VASSAL.tools.io.ProcessLauncher - launching /Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java -Xms256M -Xmx512M -DVASSAL.id=1 -DVASSAL.port=53861 -Duser.home=/Users/eadamiano -Duser.dir=/Applications/VASSAL.app -cp Contents/Resources/Java/Vengine.jar -Xdock:name=Star Wars X-Wing Miniatures Game -Xdock:icon=/Applications/VASSAL.app/Contents/Resources/VASSAL.icns -Dapple.awt.graphics.UseQuartz=false VASSAL.launch.Player --load -- /Users/eadamiano/Desktop/Vassal/Star_Wars_X-Wing_Miniatures_Game-8.8.1-1.vmod
2020-04-01 08:46:48,311 [1-main] INFO VASSAL.launch.StartUp - Starting
2020-04-01 08:46:48,325 [1-main] INFO VASSAL.launch.StartUp - OS Mac OS X 10.13.6
2020-04-01 08:46:48,325 [1-main] INFO VASSAL.launch.StartUp - Java version 1.6.0_65
2020-04-01 08:46:48,325 [1-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.17
2020-04-01 08:46:48,325 [1-main] INFO VASSAL.launch.Launcher - Player
2020-04-01 08:46:50,656 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - VASSAL images folder found at jar:file:/Applications/VASSAL.app/Contents/Resources/Java/Vengine.jar!/images/
2020-04-01 08:46:50,660 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family network-server created for network-server.png
2020-04-01 08:46:50,661 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family go-down created for go-down.png
2020-04-01 08:46:50,661 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family network-idle created for network-idle.png
2020-04-01 08:46:50,661 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family VASSAL created for VASSAL.png
2020-04-01 08:46:50,661 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family calculator created for calculator.png
2020-04-01 08:46:50,661 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family go-up created for go-up.png
2020-04-01 08:46:50,661 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family VASSAL-jabber created for VASSAL-jabber.png
2020-04-01 08:46:50,661 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family jabber created for jabber.png
2020-04-01 08:46:50,662 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family bug created for bug.png
2020-04-01 08:46:50,662 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family yes created for yes.svg
2020-04-01 08:46:50,662 [1-IconFactory-preload] INFO VASSAL.tools.icon.IconFactory - Icon family no created for no.svg
2020-04-01 08:46:54,621 [1-AWT-EventQueue-0] WARN VASSAL.launch.BasicModule - Star Wars X-Wing Miniatures Game version 8.8.1
2020-04-01 08:50:26,277 [0-ProcessLauncher-2] WARN VASSAL.tools.logging.LoggedOutputStream - 2020-04-01 09:50:26.275 java[36220:3115963] -_cgsEventRecord is deprecated for _cgsEventRecord. Please use -CGEvent.
2020-04-01 08:50:26,280 [0-ProcessLauncher-2] WARN VASSAL.tools.logging.LoggedOutputStream - 2020-04-01 09:50:26.275 java[36220:3115963] *** Assertion failure in -[NSEvent _cgsEventRecord], /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppKit/AppKit-1561.60.100/AppKit.subproj/NSEvent.m:1972
2020-04-01 08:50:26,285 [1-AWT-EventQueue-0] ERROR VASSAL.tools.ErrorDialog -
java.lang.RuntimeException: Non-Java exception raised, not handled! (Original problem: Deprecated in 10_12... DO NOT EVER USE CGSEventRecord directly. Bad things, man.... bad things.)
at apple.awt.ComponentModel._handleEvent(Native Method) ~[na:na]
at apple.awt.ComponentModel.handleEvent(ComponentModel.java:273) ~[na:na]
at apple.awt.CWindow.handleEvent(CWindow.java:545) ~[na:na]
at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:753) ~[na:1.6.0_65]
at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1000) ~[na:1.6.0_65]
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:865) ~[na:1.6.0_65]
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:686) ~[na:1.6.0_65]
at java.awt.Component.dispatchEventImpl(Component.java:4648) ~[na:1.6.0_65]
at java.awt.Container.dispatchEventImpl(Container.java:2142) ~[na:1.6.0_65]
at java.awt.Window.dispatchEventImpl(Window.java:2492) ~[na:1.6.0_65]
at java.awt.Component.dispatchEvent(Component.java:4604) ~[na:1.6.0_65]
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:717) ~[na:1.6.0_65]
at java.awt.EventQueue.access$400(EventQueue.java:82) ~[na:1.6.0_65]
at java.awt.EventQueue$2.run(EventQueue.java:676) ~[na:1.6.0_65]
at java.awt.EventQueue$2.run(EventQueue.java:674) ~[na:1.6.0_65]
at java.security.AccessController.doPrivileged(Native Method) ~[na:1.6.0_65]
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:86) ~[na:1.6.0_65]
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:97) ~[na:1.6.0_65]
at java.awt.EventQueue$3.run(EventQueue.java:690) ~[na:1.6.0_65]
at java.awt.EventQueue$3.run(EventQueue.java:688) ~[na:1.6.0_65]
at java.security.AccessController.doPrivileged(Native Method) ~[na:1.6.0_65]
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:86) ~[na:1.6.0_65]
at java.awt.EventQueue.dispatchEvent(EventQueue.java:687) ~[na:1.6.0_65]
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296) [na:1.6.0_65]
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211) [na:1.6.0_65]
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201) [na:1.6.0_65]
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196) [na:1.6.0_65]
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188) [na:1.6.0_65]
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122) [na:1.6.0_65]
MaxSterling
 
Posts: 1
Joined: April 1st, 2020, 2:56 pm

Re: modules will not open

Postby uckelman » April 5th, 2020, 9:06 pm

Thus spake MaxSterling:
> VASSAL.tools.logging.LoggedOutputStream - 2020-04-01 09:50:26.275
> java[36220:3115963] -_cgsEventRecord is deprecated for _cgsEventRecord.
> Please use -CGEvent.
> 2020-04-01 08:50:26,280 [0-ProcessLauncher-2] WARN
> VASSAL.tools.logging.LoggedOutputStream - 2020-04-01 09:50:26.275
> java[36220:3115963] *** Assertion failure in -[NSEvent _cgsEventRecord],
> /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppKit/AppKit-1561.60.100/AppKit.subproj/NSEvent.m:1972
> 2020-04-01 08:50:26,285 [1-AWT-EventQueue-0] ERROR
> VASSAL.tools.ErrorDialog -
> java.lang.RuntimeException: Non-Java exception raised, not handled!
> (Original problem: Deprecated in 10_12... DO NOT EVER USE CGSEventRecord
> directly. Bad things, man.... bad things.)
> at apple.awt.ComponentModel._handleEvent(Native Method) ~[na:na]

This bit of the errorLog is recording that something went wrong in what
looks like Apple-specific code in your version of Java. As you're using
Java 6, you might see if you can upgrade to Java 7 or Java 8. (Nothing
after Java 8 will work with 3.2.17, so don't go past Java 8.)

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8555
Joined: December 10th, 2007, 9:48 am
Location: Durham, England


Return to Technical Support & Bugs

Who is online

Users browsing this forum: cemoreno and 2 guests