Create account / Log in

Problems with Fields of Despair module 1.3

Support for existing Vassal modules. Ask here if you need help with a specific module.

Moderators: Tim M, uckelman

Problems with Fields of Despair module 1.3

Postby derekrledr » June 5th, 2018, 5:19 am

I recently tried to play a PBEM game of Fields of Despair using VASSAL module v. 1.3... and ran into a couple of issues. Here is copy of a post I sent to the Vassal Wargamers America group... as I had seen pictures posted there of a VASSAL game.
[Sigh... more hidden unit issues with Fields of Despair module 1.3. Because of my previous experience with trying to hide units in solo mode... I sent a test file to my opponent to check that hidden units were working properly with 2 players. I loaded the Introductory scenario and signed in as AP. I clicked on the Hide (AP) button and was immediately dismayed. All of my AP units had a white line appear around the outer edges... suggesting that my units had been hidden. Unfortunately, the white line also appeared around the CP units. Sure enough... when my opponent loaded the file as the CP player... the CP units were also hidden. When my opponent clicked on Hide (CP) button... nothing happened.]

I did receive a response as follows (I haven't asked the responder if I can identify him... so I am just posting the problem he identifies for now)...
[You're not doing anything wrong, this is just a design problem. The property match expression on the Global Key Command attached to the toolbar button that purports to hide only AP units is faulty.
{ObscuredToOthers=="false"&&PlayerSide=="AP"&&CurrentMap=="Main Map"}
This returns a value of true for ALL blocks on the map (what you're experiencing), thus masks them all.
Also, in response to: "When my opponent clicked on Hide (CP) button... nothing happened."
The property match on the corresponding Hide CP button looks like the above, but with "CP" in place of "AP". This returned nothing for your opponent because after you used the Hide AP button, the value of ObscuredToOthers for all blocks became "true".

I also noticed that there are no dummy counters (value 0) for the Artillery and Airplanes on the Player cards or in the Force Pools (There should be one of each)
derekrledr
 
Posts: 22
Joined: March 4th, 2008, 6:45 am

Re: Problems with Fields of Despair module 1.3

Postby T-Mo » September 10th, 2018, 1:08 am

The 0 Value Air and Artillery are there - you just have to move the ones with a value and the 0 ones are at the bottom
T-Mo
 
Posts: 6
Joined: January 28th, 2014, 9:07 pm

Re: Problems with Fields of Despair module 1.3

Postby derekrledr » September 13th, 2018, 8:12 pm

Thank you very much, Terry!
derekrledr
 
Posts: 22
Joined: March 4th, 2008, 6:45 am

Re: Problems with Fields of Despair module 1.3

Postby derekrledr » September 14th, 2018, 9:19 pm

Terry is quite right on this... and with that... the module becomes playable for me. Before I started whining... when I moved the cursor over the Artillery or Aircraft stacks... only the non-zero counters would be highlighted. However, after Terry's comment... if I moved those counters away... the dummy (0) counters were there.

As for the hidden unit issue... individual units on the map can be hidden... and individual units or groups of units can be hidden in the Force Pool window before they are brought onto the map... so while a fix for the Hide (AP) button issue described above would be nice... the module is playable without one... and this is a very fun game!
derekrledr
 
Posts: 22
Joined: March 4th, 2008, 6:45 am


Return to Module Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron