Create account / Log in

Font Size with high dpi monitor on linux

Issues with the Vassal engine.

Moderators: Tim M, uckelman

Font Size with high dpi monitor on linux

Postby peterjohnhartman » July 8th, 2018, 1:08 am

Hi,

I have a macbook pro running archlinux; the font size is very hard to read. I tried a few things, but nothing seemed to work. Any tips?

This is all VASSAL 3.2.17 and Archlinux.

export _JAVA_OPTIONS="-Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel -Dawt.useSystemAAFontSettings=on -Dsun.java2d.dpiaware=true"
cd /usr/share/java/vassal && java -classpath lib/Vengine.jar VASSAL.launch.ModuleManager "$@"

With OpenJDK 7 or 8, this results in no change.

With OpenJDK 9 or 10 I get the following error on start:

peterjh@palude /usr/bin $ ./vassal
Picked up _JAVA_OPTIONS: -Dswing.defaultlaf=com.sun.java.swing.plaf.metal -Dawt.useSystemAAFontSettings=on -Dsun.java2d.dpiaware=true
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by VASSAL.tools.image.ImageIOImageLoader (file:/usr/share/java/vassal/lib/Vengine.jar) to field sun.java2d.cmm.ProfileDeferralMgr.deferring
WARNING: Please consider reporting this to the maintainers of VASSAL.tools.image.ImageIOImageLoader
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

And when I open a module (like ASL), I get a crash -- error.log attached.

Thanks in advance.
peterjohnhartman
 
Posts: 3
Joined: July 7th, 2018, 7:28 pm

Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 4 guests