Create account / Log in

Exception launching Vasssal on Mac

Issues with the Vassal engine.

Moderators: Tim M, uckelman

Exception launching Vasssal on Mac

Postby lagouyn » July 12th, 2019, 4:34 pm

Hello.

All of a sudden, I'm getting an exception shortly after Vassal has launched.

Model: Apple MacBook Pro
OS: 10.13.6 (High Sierra)
CPU: 2.9 GHz Intel Core i7
Memory: 16GB
Video: Radeon Pro 560 4096 MB graphics
VASSAL: 3.2.17
Java: 1.8.0_111
Module: *none*

After launching, Vassal appears in the Dock for several seconds, and then terminates. Error log contents:

2019-07-12 09:21:38,770 [0-main] INFO VASSAL.launch.StartUp - Starting
2019-07-12 09:21:38,775 [0-main] INFO VASSAL.launch.StartUp - OS Mac OS X 10.13.6
2019-07-12 09:21:38,775 [0-main] INFO VASSAL.launch.StartUp - Java version 1.8.0_211
2019-07-12 09:21:38,775 [0-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.17
2019-07-12 09:21:39,142 [0-AWT-EventQueue-0] INFO VASSAL.launch.ModuleManager - Manager
2019-07-12 09:21:39,168 [0-AWT-EventQueue-0] ERROR VASSAL.tools.ErrorDialog -
java.lang.ExceptionInInitializerError: null
at VASSAL.launch.ModuleManager.launch(ModuleManager.java:455) ~[Vengine.jar:na]
at VASSAL.launch.ModuleManager$2.run(ModuleManager.java:342) ~[Vengine.jar:na]
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311) ~[na:1.8.0_211]
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758) ~[na:1.8.0_211]
at java.awt.EventQueue.access$500(EventQueue.java:97) ~[na:1.8.0_211]
at java.awt.EventQueue$3.run(EventQueue.java:709) ~[na:1.8.0_211]
at java.awt.EventQueue$3.run(EventQueue.java:703) ~[na:1.8.0_211]
at java.security.AccessController.doPrivileged(Native Method) ~[na:1.8.0_211]
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74) ~[na:1.8.0_211]
at java.awt.EventQueue.dispatchEvent(EventQueue.java:728) ~[na:1.8.0_211]
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205) [na:1.8.0_211]
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116) [na:1.8.0_211]
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105) [na:1.8.0_211]
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101) [na:1.8.0_211]
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93) [na:1.8.0_211]
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82) [na:1.8.0_211]
Caused by: java.lang.NullPointerException: null
at java.awt.Window.init(Window.java:497) ~[na:1.8.0_211]
at java.awt.Window.<init>(Window.java:537) ~[na:1.8.0_211]
at java.awt.Frame.<init>(Frame.java:420) ~[na:1.8.0_211]
at java.awt.Frame.<init>(Frame.java:385) ~[na:1.8.0_211]
at javax.swing.JFrame.<init>(JFrame.java:189) ~[na:1.8.0_211]
at VASSAL.launch.ModuleManagerWindow.<init>(ModuleManagerWindow.java:180) ~[Vengine.jar:na]
at VASSAL.launch.ModuleManagerWindow.<clinit>(ModuleManagerWindow.java:178) ~[Vengine.jar:na]
... 16 common frames omitted

Could someone help me with this?
-Allan
lagouyn
 
Posts: 2
Joined: July 12th, 2019, 4:27 pm

Re: Exception launching Vasssal on Mac

Postby lagouyn » July 15th, 2019, 1:43 pm

Update:
I was using an external monitor. Once I unplugged the monitor and re-launched on the laptop's display, it worked correctly. After that, I was once again able to run it on the external monitor.
-Allan
lagouyn
 
Posts: 2
Joined: July 12th, 2019, 4:27 pm


Return to Technical Support & Bugs

Who is online

Users browsing this forum: MSN [Bot] and 1 guest