Create account / Log in

WARNING at startup

Issues with the Vassal engine.

Moderators: Tim M, uckelman

WARNING at startup

Postby starglide » May 18th, 2020, 10:23 am

I have just installed Vassal 3.2.17-linux
I am on an Ubuntu 18.04.4 LTS laptop

I launched from the terminal, this is the warning I get. The program seems to be running fine.

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by VASSAL.tools.image.ImageIOImageLoader (file:/home/username/Vassal/lib/Vengine.jar) to field sun.java2d.cmm.ProfileDeferralMgr.deferring
WARNING: Please consider reporting this to the maintainers of VASSAL.tools.image.ImageIOImageLoader
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
starglide
 
Posts: 2
Joined: May 18th, 2020, 10:12 am

Re: WARNING at startup

Postby uckelman » May 18th, 2020, 12:14 pm

VASSAL 3.2.17 isn't compatible with Java 9 or later. (You're probably using Java 11 on Ubuntu.)

VASSAL 3.3.0, which is in beta now, is compatible with Java 9 or later. Either use that, or install Java 8.
User avatar
uckelman
Site Admin
 
Posts: 8369
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: WARNING at startup

Postby shilinski » May 18th, 2020, 4:43 pm

uckelman wrote:VASSAL 3.2.17 isn't compatible with Java 9 or later. (You're probably using Java 11 on Ubuntu.)

VASSAL 3.3.0, which is in beta now, is compatible with Java 9 or later. Either use that, or install Java 8.

Wouldn't it be better and easier to catch some of these exceptions and show an explanation in a dialog box?
shilinski
 
Posts: 142
Joined: December 22nd, 2007, 8:46 am
Location: Laurel, Maryland

Re: WARNING at startup

Postby uckelman » May 18th, 2020, 6:12 pm

Thus spake shilinski:
>
> "uckelman" wrote:
> > VASSAL 3.2.17 isn't compatible with Java 9 or later. (You're probably
> > using Java 11 on Ubuntu.)
> >
> > VASSAL 3.3.0, which is in beta now, is compatible with Java 9 or
> > later. Either use that, or install Java 8.
>
> Wouldn't it be better and easier to catch some of these exceptions and
> show an explanation in a dialog box?

Yes, and it's already done: The Linux start script for 3.3.0 prints a
message telling you that you need at least Java 11.

(Sorry, the above should have said Java 11, not Java 9. This changed
betwen beta2 and beta3.)

--
J.
User avatar
uckelman
Site Admin
 
Posts: 8369
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: WARNING at startup

Postby starglide » May 20th, 2020, 7:27 am

Installed the beta! Thanks a lot for helping!
starglide
 
Posts: 2
Joined: May 18th, 2020, 10:12 am


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 3 guests