Create account / Log in

VASSAL Losing Connection to Server

Issues with the Vassal engine.

Moderators: Tim M, uckelman

VASSAL Losing Connection to Server

Postby eggsalad » November 9th, 2016, 6:05 pm

Hello -- I've done some searching of the forums for this topic and found some threads, but nothing so far that has helped get me any closer to a solution.

I have a windows 10 PC with VASSAL 3.2.16. When I join an online game, or start a room of my own, I will lose connection to the server after ~3-5 minutes of no activity in the module.

I understand that the problem is likely in my firewall/router/ISP. However, VASSAL is the only program that has this issue. I have experienced no other connection problems with any other internet connection on this system.

I have run tracert and ping to the VASSAL server, and the results are always good.

Given that, are there some resources that someone can point me to help troubleshoot this issue, most likely from a firewall / router configuration perspective? Is there a description of how the VASSAL connection to the server works that might help me understand why only the VASSAL connections are being dropped?

I have tried adding VASSAL and the java exe explicitly to the firewall on my PC, no luck. I am loathe to turn the firewall off entirely, but I suppose I could try that. I have also looked into my router settings and could not find any obvious tweaks to make to prevent a timeout.

I appreciate any help / resources folks can give me.
eggsalad
 
Posts: 2
Joined: July 19th, 2013, 4:34 pm

Re: VASSAL Losing Connection to Server

Postby JohnStaal » January 10th, 2019, 12:02 am

Hi,
Ever got a solution direction for this problem?

Very interested because I suffer from same issue and would like to solve this.

Regards, John
JohnStaal
 
Posts: 6
Joined: October 19th, 2016, 10:34 pm

Re: VASSAL Losing Connection to Server

Postby wifferboy » January 13th, 2019, 6:25 am

I also have this problem and have searched the forums and have found nothing to help. And yet it seems to be happening to many of us.

Is there some kind of an activity timer involved?
wifferboy
 
Posts: 53
Joined: March 22nd, 2011, 9:50 pm


Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 3 guests