Update – Virgin Queen v2.0

A major update to the Virgin Queen has been released. The module features a number of improvements to the handling of control markers, stocking on-map treasure boxes, and now automatically adjusts VPs in almost all situations.

This module now requires VASSAL 3.2.2 or higher.