VASSAL 3.3.1 Released

The VASSAL Team is happy to announce the release of VASSAL 3.3.1.

IMPORTANT

  • Things may be broken which worked in 3.2.17. If you find a bug introduced since 3.2.17, please report it.
  • If you save a module in VASSAL 3.3, you will NOT be able to open it afterwards with VASSAL 3.2. We recommend keeping a backup copy of any pre-3.3 modules you plan to modify in 3.3 until you’ve verified that everything works to your satisfaction.
  • Some modules containing custom drawing code may render incorrectly on HiDPI displays. If you are the maintainer of such a module, let us know and we can advise you about what needs updating for 3.3 in your code. (We are aware already that VASL has this problem and are working with its maintainers to update it.)

Download

Changes since 3.3.0

Bug fixes:

  • 13111: IncompatibleClassChangeError due to change of ComponentSplitter methods to static prevents some modules from opening
  • 13083: BrowserSupport cannot open URLs on Linux without gtk3

For changes prior to this release, see the change log.

Minimum Requirements

VASSAL 3.3 requires Java 11 or later.

The Windows and Mac packages have an appropriate version of Java bundled with them, so there is no need to install Java separately on those operating systems.

Help us test

Should you find any problems/oddities/bugs, please tell us so that we can fix them for a future release of VASSAL. Report bugs here in the Technical Support & Bugs category at the VASSAL forums or by email.

Cheers,
The VASSAL Team