All posts by uckelman

VASSAL 3.3.2 Released

The VASSAL Team is happy to announce the release of VASSAL 3.3.2.

IMPORTANT

  • Things may be broken which worked in 3.2.17. If you find a bug introduced since 3.2.17, please report it.
  • If you save a module in VASSAL 3.3, you will NOT be able to open it afterwards with VASSAL 3.2. We recommend keeping a backup copy of any pre-3.3 modules you plan to modify in 3.3 until you’ve verified that everything works to your satisfaction.
  • Some modules containing custom drawing code may render incorrectly on HiDPI displays. If you are the maintainer of such a module, let us know and we can advise you about what needs updating for 3.3 in your code. (We are aware already that VASL has this problem and are working with its maintainers to update it.)

Download

Changes since 3.3.1

  • 13182: Piece images in Inventory windows are drawn offset on HiDPI screens
  • 13181: Piece images in Inventory windows have truncated height on Macs
  • 13176: Bundled Java fails to start on Mac OS X < 10.13
  • 13175: Add bundle for 32-bit Windows
  • 13152: Version number and year set incorrectly in Mac DMG’s Info.plist
  • 13143: HTTPS URLs fail to load (handshake_failure) due to missing jdk.crypto.ec module
  • 13140: Versions with a build number are incorrectly sorted before versions without a build number
  • 13136: Update notifier still has old SourceForge URL for downloads
  • 13126: Right mouse button and Control-Click broken on Macs
  • 12861: Improved behavior of Zone editor

For changes prior to this release, see the change log.

Minimum Requirements

VASSAL 3.3 requires Java 11 or later.

The Windows and Mac packages have an appropriate version of Java bundled with them, so there is no need to install Java separately on those operating systems.

Help us test

Should you find any problems/oddities/bugs, please tell us so that we can fix them for a future release of VASSAL. Report bugs here in the Technical Support & Bugs category at the VASSAL forums or by email.

Cheers,
The VASSAL Team

VASSAL 3.3.1 Released

The VASSAL Team is happy to announce the release of VASSAL 3.3.1.

IMPORTANT

  • Things may be broken which worked in 3.2.17. If you find a bug introduced since 3.2.17, please report it.
  • If you save a module in VASSAL 3.3, you will NOT be able to open it afterwards with VASSAL 3.2. We recommend keeping a backup copy of any pre-3.3 modules you plan to modify in 3.3 until you’ve verified that everything works to your satisfaction.
  • Some modules containing custom drawing code may render incorrectly on HiDPI displays. If you are the maintainer of such a module, let us know and we can advise you about what needs updating for 3.3 in your code. (We are aware already that VASL has this problem and are working with its maintainers to update it.)

Download

Changes since 3.3.0

Bug fixes:

  • 13111: IncompatibleClassChangeError due to change of ComponentSplitter methods to static prevents some modules from opening
  • 13083: BrowserSupport cannot open URLs on Linux without gtk3

For changes prior to this release, see the change log.

Minimum Requirements

VASSAL 3.3 requires Java 11 or later.

The Windows and Mac packages have an appropriate version of Java bundled with them, so there is no need to install Java separately on those operating systems.

Help us test

Should you find any problems/oddities/bugs, please tell us so that we can fix them for a future release of VASSAL. Report bugs here in the Technical Support & Bugs category at the VASSAL forums or by email.

Cheers,
The VASSAL Team

VASSAL 3.3.0 Released

The VASSAL Team is happy to announce the release of VASSAL 3.3.0.

IMPORTANT

  • Things may be broken which worked in 3.2.17. If you find a bug introduced since 3.2.17, please report it.
  • If you save a module in VASSAL 3.3, you will NOT be able to open it afterwards with VASSAL 3.2. We recommend keeping a backup copy of any pre-3.3 modules you plan to modify in 3.3 until you’ve verified that everything works to your satisfaction.
  • Some modules containing custom drawing code may render incorrectly on HiDPI displays. If you are the maintainer of such a module, let us know and we can advise you about what needs updating for 3.3 in your code. (We are aware already that VASL has this problem and are working with its maintainers to update it.)

Download

Changes since 3.2.17

  • 13103: Windows installer checks for 64-bit Windows, as bundled Java is 64-bit
  • 12973: Unnecessary NullCommands being generated by Trigger Action
  • 12861: Improved behavior of Zone editor
  • 12825: Send keep-alive to prevent disconnection
  • 12817: Right-clicking on unexpanded stacks no longer selects top piece
  • 12816: Splitter between chat and map panes starts with map obscured
  • 12805: Upgraded Batik from 1.12 to 1.13
  • 12732: Use all available rendering hints for text
  • 12731: javax.sound.samples.Clip fails to convert WAV files it can play
  • 12724: Bundle Java 14 with Windows and Mac packages
  • 12613: Advance maximum custom class version to Java 11
  • 12579: Don’t bundle Java on Linux
  • 12559: HiDPI support
  • 12558: Bundle Java with VASSAL
  • 12557: Compatibility with Java 9+
  • 12556: Mass Piece Definer does not sort image names
  • 12544: MacOS launcher not finding correct Java install

For changes prior to this release, see the change log.

Minimum Requirements

VASSAL 3.3 requires Java 11 or later.

The Windows and Mac packages have an appropriate version of Java bundled with them, so there is no need to install Java separately on those operating systems.

Help us test

Should you find any problems/oddities/bugs, please tell us so that we can fix them for a future release of VASSAL. Report bugs here in the Technical Support & Bugs category at the VASSAL forums or by email.

Cheers,
The VASSAL Team

VASSAL 3.3.0-beta4 Released

The VASSAL Team is happy to announce the release of VASSAL 3.3.0-beta4.

IMPORTANT

  • This is a beta release. Things may be broken which worked in 3.2.17. If you find a bug introduced since 3.2.17, please report it.
  • If you save a module in VASSAL 3.3, you will NOT be able to open it afterwards with VASSAL 3.2. We recommend keeping a backup copy of any pre-3.3 modules you plan to modify in 3.3 until you’ve verified that everything works to your satisfaction.
  • Some modules containing custom drawing code may render incorrectly on HiDPI displays. If you are the maintainer of such a module, let us know and we can advise you about what needs updating for 3.3 in your code. (We are aware already that VASL has this problem and are working with its maintainers to update it.)

Download

Changes since 3.3.0-beta3

  • 12973: Unnecessary NullCommands being generated by Trigger Action
  • 12861: Improved behavior of Zone editor
  • 12825: Send keep-alive to prevent disconnection
  • 12817: Right-clicking on unexpanded stacks no longer selects top piece
  • 12816: Splitter between chat and map panes starts with map obscured
  • 12805: Upgraded Batik from 1.12 to 1.13

For changes prior to this release, see the change log.

Minimum Requirements

VASSAL 3.3 requires Java 11 or later.

The Windows and Mac packages have an appropriate version of Java bundled with them, so there is no need to install Java separately on those operating systems.

Help us test

Should you find any problems/oddities/bugs, please tell us so that we can fix them for a future release of VASSAL. Report bugs here in the Technical Support & Bugs category at the VASSAL forums or by email.

Cheers,
The VASSAL Team

VASSAL 3.3.0-beta3 Released

The VASSAL Team is happy to announce the release of VASSAL 3.3.0-beta3.

IMPORTANT

  • This is a beta release. Things may be broken which worked in 3.2.17. If you find a bug introduced since 3.2.17, please report it.
  • If you save a module in VASSAL 3.3, you will NOT be able to open it afterwards with VASSAL 3.2. We recommend keeping a backup copy of any pre-3.3 modules you plan to modify in 3.3 until you’ve verified that everything works to your satisfaction.
  • Some modules containing custom drawing code may render incorrectly on HiDPI displays. If you are the maintainer of such a module, let us know and we can advise you about what needs updating for 3.3 in your code. (We are aware already that VASL has this problem and are working with its maintainers to update it.)

Download

New in 3.3.0

Features:

  • 12557, 12613: Compatibility with Java 9+: VASSAL 3.2 would not run with anything newer than Java 8. VASSAL 3.3 now requires Java 11 or later.
  • 12558, 12724: Bundle Java with VASSAL: The Mac and Windows packages now include Java 14. It is no longer necessary to install Java separately when using one of these packages.
  • 12559: HiDPI support: VASSAL now has support for displays with a high pixel density (e.g., Retina displays). On such displays, you should now see correctly sized interface elements and sharper image rendering.

Bug fixes in 3.3.0-beta3:

  • 12732: Use all available rendering hints for text
  • 12731: javax.sound.samples.Clip fails to convert WAV files it can play

Bug fixes in 3.3.0-beta2:

  • 12579: Don’t bundle Java on Linux

Bug fixes in 3.3.0-beta1:

  • 12556: Mass Piece Definer does not sort image names

For changes prior to 3.3.0-beta1, see the change log.

Minimum Requirements

VASSAL 3.3 requires Java 11 or later.

The Windows and Mac packages have an appropriate version of Java bundled with them, so there is no need to install Java separately on those operating systems.

Help us test

Should you find any problems/oddities/bugs, please tell us so that we can fix them for a future release of VASSAL. Report bugs here in the Technical Support & Bugs category at the VASSAL forums or by email.

Cheers,
The VASSAL Team

VASSAL 3.3.0-beta2 Released

The VASSAL Team is happy to announce the release of VASSAL 3.3.0-beta2.

IMPORTANT

  • This is a beta release. Things may be broken which worked in 3.2.17. If you find a bug introduced since 3.2.17, please report it.
  • If you save a module in VASSAL 3.3, you will NOT be able to open it afterwards with VASSAL 3.2. We recommend keeping a backup copy of any pre-3.3 modules you plan to modify in 3.3 until you’ve verified that everything works to your satisfaction.
  • Some modules containing custom drawing code may render incorrectly on HiDPI displays. If you are the maintainer of such a module, let us know and we can advise you about what needs updating for 3.3 in your code. (We are aware already that VASL has this problem and are working with its maintainers to update it.)

Download

New in 3.3.0

Features:

  • 12557: Compatibility with Java 9+: VASSAL 3.2 would not run with anything newer than Java 8. VASSAL 3.3 now requires Java 9 or later.
  • 12558: Bundle Java with VASSAL: The Mac and Windows packages now include Java 13. It is no longer necessary to install Java separately when using one of these packages.
  • 12559: HiDPI support: VASSAL now has support for displays with a high pixel density (e.g., Retina displays). On such displays, you should now see correctly sized interface elements and sharper image rendering.

Bug fixes in 3.3.0-beta2:

  • 12579: Don’t bundle Java on Linux

Bug fixes in 3.3.0-beta1:

  • 12556: Mass Piece Definer does not sort image names

For changes prior to 3.3.0-beta1, see the change log.

Minimum Requirements

VASSAL 3.3 requires Java 9 or later.

The Windows and Mac packages have an appropriate version of Java bundled with them, so there is no need to install Java separately on those operating systems.

Help us test

Should you find any problems/oddities/bugs, please tell us so that we can fix them for a future release of VASSAL. Report bugs here in the Technical Support & Bugs category at the VASSAL forums or by email.

Cheers,
The VASSAL Team

VASSAL 3.3.0-beta1 Released

The VASSAL Team is happy to announce the release of VASSAL 3.3.0-beta1.

IMPORTANT

  • This is a beta release. Things may be broken which worked in 3.2.17. If you find a bug introduced since 3.2.17, please report it.
  • If you save a module, game, or log in VASSAL 3.3, you will NOT be able to open it afterwards with VASSAL 3.2. We recommend keeping a backup copy of any pre-3.3 files you plan to modify in 3.3 until you’ve verified that everything works to your satisfaction.
  • Some modules containing custom drawing code may render incorrectly on HiDPI displays. If you are the maintainer of such a module, let us know and we can advise you about what needs updating for 3.3 in your code. (We are aware already that VASL has this problem and are working with its maintainers to update it.)

Download

New in 3.3.0-beta1

Features:

  • 12557: Compatibility with Java 9+: VASSAL 3.2 would not run with anything newer than Java 8. VASSAL 3.3 now requires Java 9 or later.
  • 12558: Bundle Java with VASSAL: The Linux, Mac, and Windows packages now include Java 13. It is no longer necessary to install Java separately when using one of these packages.
  • 12559: HiDPI support: VASSAL now has support for displays with a high pixel density (e.g., Retina displays). On such displays, you should now see correctly sized interface elements and sharper image rendering.

Bug fixes:

  • 12556: Mass Piece Definer does not sort image names

For changes prior to 3.3.0-beta1, see the change log.

Please report all bugs in 3.3.0-beta1 even if they are bugs which you’ve already reported against other versions. We take your bug reports seriously—they’re the reason we’ve been able to fix so many bugs.

Minimum Requirements

VASSAL 3.3 requires Java 9 or later.

Help us test

Should you find any problems/oddities/bugs, please tell us so that we can fix them for a future release of VASSAL. Report bugs here in the Technical Support & Bugs category at the VASSAL forums or by email.

Cheers,
The VASSAL Team

VASSAL 3.2.17 Released

The VASSAL Team is happy to announce the release of VASSAL 3.2.17, which which fixes several problems found in earlier versions.

IMPORTANT

  • If you save a module, game, or log in VASSAL 3.2, you will NOT be able to open it afterwards with VASSAL 3.1. We recommend keeping a backup copy of any pre-3.2 files you plan to modify in 3.2 until you’ve verified that everything works to your satisfaction.
  • If you found it necessary to set a very large maximum heap (> 512MB) for a module with VASSAL 3.1, it should now be possible with VASSAL 3.2 to set a much lower maximum heap and achieve similar or better display performance. 512MB should now be adequate for most modules.
  • VASL 6 is compatible with VASSAL 3.2. VASL users, please upgrade!
  • If some images display with incorrect colors, clear your tile cache (under Tools > Clear Tile Cache in the Module Manager) and reload the module. If the images still display with incorrect colors, PLEASE contact us indicating with which module you’re seeing a problem.
  • If you are using MacOS X 10.8.3 or later, you may see the message “VASSAL-3.2.17.app is damaged and can’t be opened. You should move it to the Trash.” The problem is NOT that your download was corrupt, but rather that MacOS is preventing you from running VASSAL. To start VASSAL, control-click or right-click the app bundle’s icon and select Open from the menu. You’ll see a dialog asking whether you want to open VASSAL. Select “Open”. Thereafter, you should be able to start VASSAL normally.
  • Oracle’s Java 7 and 8 have very poor rendering performance on some MacOS X systems, particularly Yosemite. If you are experiencing this, please use Apple’s Java 6 instead.

Download

Recent Changes

The following bugs in 3.2.16 are fixed in 3.2.17:

  • 12534: Regular Expression matching not supported in Calulated Property
  • 12533: Game Refresher fails if Extensions are loaded
  • 12527: “Save Game” behaves as “Save As”
  • 12526: Switching desktop on Mac OS X 10.11.3 sometimes clones the currently selected unit
  • 12518: Rotated Layer following property does not update if property changes
  • 11649: Persistent LOS thread not working with zoom different from 100%
  • 11404: Some uses of the PRNG introduce a minuscule amount of modulo bias
  • 9670: IllegalStateException: Icon Family VASSAL not found in ServerAddressBook.getCurrentIcon

The following bugs in 3.2.15 are fixed in 3.2.16:

  • 12524: Images retile unnecessarily due to bad timestamp
  • 12522: Deck shuffling logged incorrectly

For changes prior to 3.2.16, see the change log.

Please report all bugs in 3.2.17 even if they are bugs which you’ve already reported against other versions. We take your bug reports seriously—they’re the reason we’ve been able to fix so many bugs.

New Features in 3.2

  • Levels within a Layer can be moved up or down the level list using buttons. [RFE 1919]
  • Mass Piece Loader activated by ‘Add Multiple Pieces’ and ‘Add Multiple Cards’ options in right-click menu in Editor. Specify a folder of images, specify a counter template and Vassal will automatically load the images and generate units. [RFE 1927]
  • Description field added to Toolbar Menu and Multi-Action button components. [RFE 1885]
  • Specify Keystrokes by name – Key Commands can be entered as single Key Strokes as in earlier versions of Vassal, or can be given a 2 or more character names. Named Key Strokes are essentially ‘invisible’ to users. Vassal guarantees that a unique real keyStroke will be allocated to each uniquely named Keystroke. [RFE 1928]
  • Decks can specify by Property Expression which pieces are allowed to be dropped onto them. Pieces which may not be added are returned to where the drag started. [RFE 1935]
  • Decks can now specify a Hotkey for the Reverse and FaceUp/Down command and can customize the Reverse and Re-shuffle menu command names. [RFE 1938]
  • Counters now support the DeckPosition property. If a piece is not in a Deck, 0 is returned. If a piece is in a Deck, then the position of the piece relative to the top of the Deck is returned. The top piece returns 1, the next piece down returns 2 etc. [RFE 1937]
  • Support for MP3 sound files. [RFE 1934]
  • Fix Display/Color handling for Grids and Numberings. Allow Numbering to be visible when grid not visible in Zones. [RFE 1917]
  • Implementation of BeanShell allowing arbitrarily complex Java expressions to be used in Property Match Expressions, In-line Java expressions and new Calculated Property trait. [RFE 1801]
  • Display the Log File Comments in the Chat Window when a log file is opened or continued. [RFE 1939]
  • Global Key Commands created on a Map now have an option to affect counters on all Maps, not just the Map they are created on. [RFE 1902]
  • Traits that move a counter (Send To Location, Return to Deck, Moved Fixed Distance, Pivot) now update the same location Oldxxxxxx properties that Drag and Drop movement does. [RFE 1792]
  • Added repeat (loop) option to Trigger Action and Multi-action button. [RFE 1876]
  • Ensure all commands generated by a single user action are undone by a single click of the undo action. [RFE 2816016]
  • Option to allow non-owning players to move Restricted Access pieces. [RFE 1789]
  • Add ‘Snap to Grid?’ option to HexGrid and SquareGrid, defaulting to Yes. Allows Grid Snapping to be turned off for the whole grid. [RFE 2842811]
  • Streamlined room creation: automatic synchronization on room entry [RFE 1784]
  • New scenario updater [RFE 1899]
  • Allow Dynamic Property Select Value list to be dynamic [RFE 1926]
  • All scaling is now high-quality. Low-quality scaling (in hardware) caused too many graphics glitches on Windows.
  • The Invisible trait now supports adjustable transparency.
  • Map images are tiled the first time modules are loaded, to create an image cache. This should dramatically reduce the amount of memory needed to run modules.
  • Improved display of properties in the Editor [RFE 4323]:
    • Display all available properties from all components structured in the same way as the components of the module are built instead of all the global properties being dumped in one menu.
    • Available Global properties now appear without having to start a game. Previously, globals like Deck and Zone properties where not available unless you had started a game.
    • Property and component names are sorted, except for the Piece Property menu where the traits are displayed in the same order they exist in the counter.
    • If a menu has too many options to fit on the screen, it is now scrollable, instead of stretching off the screen and leaving some properties inaccessible.
  • Improvements to Layer trait [RFE 4717]:
    • Follow Property name may be a BeanShell expression.
    • Improved layout for Layer dialog in Editor.
  • Notify user when image loading fails [RFE 1887]

Minimum Requirements

VASSAL 3.2 requires the Java Runtime Envrionment to run.

Linux: Java 6 or later is required for using VASSAL on Linux.

MacOS X: The recommended minimum Java version for using VASSAL on MacOS X is 1.5.0_08 (a.k.a. Java 5 Update 8) for Macs where Java 6 is unavailable, and Java 6 or later for Macs where Java 6 is available.

Windows: The recommended minimum Java version for Windows is 1.6.0_45 (a.k.a. Java 6 Update 45). Windows users installing VASSAL with the Windows installer will be prompted to update Java if what they have is older than 1.6.0_45. After upgrading Java on Windows, you must restart your computer in order for Java programs to work properly.

If you’ve installed Java 7 on Windows and thereafter VASSAL fails to launch: The Java 7 installer does not uninstall Java 6, and having both installed simultaneously prevents both from working properly. Therefore, check whether you also still have Java 6 installed. If so, removing Java 6 and rebooting will most likely solve your problem.

Help us test

Should you find any problems/oddities/bugs, please tell us so that we can fix them for a future release of VASSAL. Report bugs here in the Technical Support & Bugs category at the VASSAL forums or by email.

Cheers,
The VASSAL Team

Wiki temporarily locked due to spamming

Our wiki was hit by a spam attack overnight, writing nearly a thousand junk pages, which have now been removed. We’ve disabled editing until we can be sure the spammers won’t be able to waste our time like this again. Expect the wiki to be editable again by tomorrow, after we’ve implemented a solution.