[messages] [Technical Support & Bugs] Black border lines appearing on images.

Robbie peteroberts1 at btinternet.com
Thu Nov 11 13:22:32 MST 2010


Model Acer Aspire 8942G
OS Windows 7
CPU Intel (R) Core (TM) i7 CPU Q720 @ 1.60GHz 1.60Ghz
Memory 6GB RAM
Graphics card ATI Mobility Radeon HD 5850
Vassal 3.1.14
Java Version 6 update 22 
Module Vasl 5.9.2.

I created an extension to provide some draggable overlays within Vasl
and have come across some strange behaviour.

The overlay images are fine at zoom levels of 100% or greater, but when
zooming to less than 100% black edge lines appear on the images – on
some images the lines are top and bottom and on others at the sides or
at sides and top or bottom. The lines differ from image to image, but
are always the same for a particular image.

On some images the orientation of the lines changes as you zoom out for
example instead of being at the top and bottom they move to the left and
right edges.

If you rotate the overlay the black edge lines disappear, but reappear
when rotated back to the original orientation. Is this a bug in
Vassal/Vasl or am I doing something wrong?

I have created previous extensions for providing draggable overlays with
Vasl and they have worked fine, in an effort to try and isolate the
problem I recreated an old extension using the same image files that I
used before and am now getting the black border lines on these images in
the new extension. I cannot remember which versions of Vassal and Vasl I
use to create this extension originally, I thought it was also with
Vassal 3.1.14 and Vasl 5.9.2, but I could be wrong.

Any help would be greatly appreciated.

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=20532#p20532


More information about the messages mailing list