[messages] [Developers] Re: How to become a Vassal developper

Joel Uckelman uckelman at nomic.net
Sun Jul 31 07:26:40 MST 2011


Thus spake zov66:
> Joel,
> 
> Oh, okay that sounds fine and all but all I am trying to do is to get
> VASSAL to complie in Eclipse. So I am not even coding anything yet.
> 
> So my basic question is since that this is old code or whatever, can I
> just delete it, comment it out or what?
> 
> Again, just trying to get the SVN down (which I did) and for it to work
> (compile) in Eclipse (which is wont).
> 
> Basically following directions that are old and not working correctly.

If you're tring to compile VASL against the trunk as-is, that can't
possibly work, because the trunk no longer contains some things which 
VASL uses. If all you want is for VASL to compile, then you could do
that by commenting out the offending code---but presumably that code is
not intended to be a no-op, so you won't produce a program which works
properly this way, just one that compiles.

Alternatively, I believe that VASL will compile against the 3.1 branch
of VASSAL without modification. However, this is only a short-term
solution. Someone will eventually need to update the VASL code to work
with the trunk.

-- 
J.


More information about the messages mailing list