[messages] [Technical Support & Bugs] Stacking and Layers stop functioning/function incorrectly?

reddeblu twilightshadow0 at hotmail.com
Tue Jul 3 18:15:17 MST 2012

I'm not sure what has happened, as the layers and stacking were working
just fine for a long time in this module I'm building, then suddenly
they started to not do what they were suppose to.

What happened was, I have some pieces set with a "Does not stack" trait,
and a "Place marker" trait. The placed markers were set to be placed
above the piece they were being placed on. Everything was fine and
worked for days, and I never touched the traits. But suddenly the placed
markers started placing underneath the piece instead of on top. Both the
placed marker and the piece it is placed on shared the same layer. So i
tried to put the piece in a lower layer then the markers, then suddenly
the markers were stacking on top of the piece. After restarting the
module, the markers started placing under the piece again, despite being
in a higher layer.

The layer property  and the "Does not stack" trait were both shared by
the two pieces originally with a single shared prototype.

I gave them both their own prototype, with the piece having a different
lower layer, when they started stacking on it.

I don't have any error message or explanation of whats causing this,
except that it seems maybe I've overloaded too many traits/commands/ect.
into the prototype/pieces/module? 

I have no idea how to reproduce it. If anyone has any ideas on this id
like to hear them.

- Custom Model Computer
- Windows XP Operating System
- Intel Core 2 Duo CPU
- 2 GB Memory
- Nvidia GeFore GTS 250 Video Card
- Vassal version 3.1.19
- Java version 1.7.0_05

In case anyone wants to look at it:

[1] http://www.mediafire.com/?hltp9xbml6cxh6g

Read this topic online here:

More information about the messages mailing list