[messages] [Developers] Java 1.5 Support?

Joel Uckelman uckelman at nomic.net
Thu Sep 6 13:00:17 MST 2012


Thus spake Brent Easton:
> Sorry Joel,
> Here you go.
> 
> 1. VASSAL.build.module.StartupGlobalKeyCommand
> @override's at lines 74,85, 89 and 96 throw an error.
> 
> 2. VASSAL.tools.BrowserSupport
> java.awt.Desktop does not exist in 1.5.
> 
> 3. VASSAL.tools.swing.EDTExecutorService
> @overrides at lines 174 and 212
> 
> The @overrides are trivial and while the Desktop issue will not compile
> under 1.5, it is not referenced if you are running 1.5, so the version
> compiled in 1.6 will never throw an error!

I've removed the overrides in trunk at 8337.

Do you mean that BrowserSupport works running under Java 1.5 if it's
compiled with 1.6? If that's so, then it doesn't need changing. We
want V3.2 to run under 1.5 (for people with old Macs) but there's no
need to restrict compilation to 1.5.
 
-- 
J.


More information about the messages mailing list