[messages] Edit: Re: [Technical Support & Bugs] 3.2.0-beta3 Does Not Work on OSX.

Joel Uckelman uckelman at nomic.net
Fri Sep 28 02:28:17 MST 2012


Thus spake tar:
> [This message has been edited.]
> 
> On Thu, Sep 27, 2012 at 10:37 PM, Howitzer99  wrote:
> 
> > Hi All,
> >
> > Myself and several others have discovered that  3.2.0-beta3 is broken
> on
> > OSX, specifically versions 10.7.4 and 10.8.2 (so far).  I've posted a
> > message on BGG regarding this, and am re-posting it here so that the
> > right people get the information.
> >
> > I've tried using the newest beta version on OSX 10.7.4, but it will
> not
> > start. The Vassal icon just bounced in the dock, and never launches.
> > Clicking the icon to raise the application causes it to close.
> >
> 
> For some reason, the application has not been built correctly.
> In particular, the JavaApplicationStub is not set to be executable.
> Launching then fails with a permission denied error.
> 
> 9/28/12 1:08:02.078 AM com.apple.launchd.peruser.501:
> ([0x0-0x9a09a].org.vassalengine.VASSAL[2768])
> posix_spawn("/Volumes/VASSAL-3.2.0-beta3/VASSAL-3.2.0-beta3.app/Contents/MacO
> S/JavaApplicationStub",
> ...): Permission denied
> 
> Manually changing the permissions to be executable fixes the problem.
>

The bad file permisions were caused by the fix for Bug 4807. Try build
3.2.0-svn8382:

http://www.vassalengine.org/~uckelman/builds/

If this works, let me know and I'll replace the 3.2.0-beta3 builds with
it.

-- 
J.


More information about the messages mailing list