[messages] [Module Design] Stumped; Layer with Text Layer

SmilodonUP strikesfirmly at yahoo.com
Fri Feb 1 17:33:28 MST 2013


_I searched about the Web and the site for a couple hours, but didn't
see a specific fix to this question. (Win XP3 32bit)_

I've been revamping a module, and wanted to add Objective flags.

There will be single versions and layered versions of both small & large
examples. I created the flags, mask, and text in the same image stack
then saved for web each layer to PNG, so everything is the same.

_These first variations all work fine with the following order;_
Basic Piece
Delete
Layer - xxx Flag
Non-Rectangular
Does Not Stack

Layer properties uses . (period) to change flags, or , (comma) to go
back to previous, with `(tilde/Back Quote) resetting to first flag due
to ctrl+f already being used, and alt+f opening the Vassal's 'file'
menu.


Now, for the larger flags specific to faction or etc, in order to not
have a whole slug of images, I've been trying to use the above set-up
with the the appropriate objectives as a text layer over the flag layer.
Because the faction images will vary, I also wanted an option to change
the text color black-blue-etc etc for a few variations.

Activating __Hold__ was supposed to be alt+l, __Scout__ alt+u, and
__Seize__ alt+z. 'C' was to change the color of each word through the
six choices, of whichever was active. 

__The problem;__
I tried all three layers as a prototype added to the flag, as individual
prototypes, and individual layers. No matter how I move the order
right-clicking the flag will show the main choices as typed into the
layer properties but only the topmost change color option, while instead
of trying to use what keys are set they show stuff like NUMPAD _. (which
doesn't exist), NUMPAD-3, alt+F6, alt+F11, and so on.... clicking will
make the layers activate as desired, and I can change the first choice
to the other colors, but no more than that. The flag layers still work
correctly.

I have even tried setting the flag layer to '_Underneath when
Highlighted_' which did nothing that I could tell, nor did forcing the
text to use a layer mask via _Non-Rectangular_.

Just at a standstill over what I'm doing wrong.

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=38368#p38368


More information about the messages mailing list