[messages] [Module Support] Many modules broken in VASSAL 3.2.2

Joel Uckelman uckelman at nomic.net
Thu Feb 28 14:54:20 MST 2013


Thus spake RedMike:
> VASL
> VSQL

There aren't 3.2-compatible releases of these yet. I've already fixed
the problem in VASL, and Brent has picked up the fix for VSQL, so you'll
see 3.2-compatible versions of these eventually.

> A Victory Lost
> Red Star Rising

You should notify the module maintainer for each of these.

> No Question of Surrender
> The Devil's Cauldron

These are Brent's. I've already sent him the fix.

> All hang when exiting.
> 
> There are probably others as well.

The problem is that these modules contain custom code which is sloppy
about closing streams, and 3.2 no longer tollerates that. If you find
other such modules, notify their maintainers.

If the module maintainers can't figure out how to fix the problem,
they should ask about it here.

-- 
J.


More information about the messages mailing list