[messages] [Technical Support & Bugs] SVG map import fails - What am I doing wrong?

blackice blackice at myrealbox.com
Thu Oct 3 22:41:27 MST 2013


Hello!

Having spent days re-creating a map by hand as .svg in Inkscape, I
wanted to import it into my module tonight. However, on attempting to
load it I get the "Unable to Read File - VASSAL was unable to read the
file '[file name]'" error message.

I have tried simpler versions of the same map, e.g. by collapsing
everything onto one layer and removing the only .svg component that I
had not created myself. The only time I managed an import was when I
stripped out everything except for the most basic shapes.

Here are the basic stats for what I am trying to import


  * Mostly hand drawn .svg file created in Inkscape
  * 10.6 MB file size
  * 4,000 x 4,400 pixel nominal size
  * About 5,000 total shapes
  * Tried loading with original eight layers as well as collapsed to
single layer
  * No embedded bitmaps or code
  * Running VASSAL 3.2.8 on Mac OS X 10.7.5 with Java 1.6.0_51 from
Apple



It seemed like this should be straightforward, but it is not (for me). I
have considered breaking the map into smaller chunks, but this would be
quite tedious in the .svg format.

Please help me figure out how to make this work – and what additional
information you need to be able to help.

It would be such a shame to export the map to PNG first. Thanks a bunch
for an assistance in advance!

– Martin

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=42274#p42274


More information about the messages mailing list